Ожидайте PECL для PHP 7

Я просто обновился до PHP 7.0.3, но поддержки не ожидается . Кто-нибудь знает, можно ли обойти проблему установки? В нем говорится:

root@portal:/home# pecl install expect-0.3.3.tgz pecl/expect requires PHP (version >= 4.0.0, version <= 5.99.99), installed version is 7.0.3-5+deb.sury.org~trusty+1 No valid packages found install failed 

Я искал в Интернете, но я не нашел никакого пакета с этой версией PHP. Он отлично работал на предыдущей установленной версии, 5.5.

На php.net есть открытая ошибка, требующая поддержки php7.

Чтобы обеспечить такую ​​поддержку, необходимо решить следующие ошибки времени компиляции.

 [ 131s] + /usr/bin/make -j1 [ 131s] /bin/sh /usr/src/packages/BUILD/expect-0.3.3/libtool --mode=compile cc -I. -I/usr/src/packages/BUILD/expect-0.3.3 -DPHP_ATOM_INC -I/usr/src/packages/BUILD/expect-0.3.3/include -I/usr/src/packages/BUILD/expect-0.3.3/main -I/usr/src/packages/BUILD/expect-0.3.3 -I/usr/include/php7 -I/usr/include/php7/main -I/usr/include/php7/TSRM -I/usr/include/php7/Zend -I/usr/include/php7/ext -I/usr/include/php7/ext/date/lib -DHAVE_CONFIG_H -g -O2 -c /usr/src/packages/BUILD/expect-0.3.3/expect.c -o expect.lo [ 131s] libtool: compile: cc -I. -I/usr/src/packages/BUILD/expect-0.3.3 -DPHP_ATOM_INC -I/usr/src/packages/BUILD/expect-0.3.3/include -I/usr/src/packages/BUILD/expect-0.3.3/main -I/usr/src/packages/BUILD/expect-0.3.3 -I/usr/include/php7 -I/usr/include/php7/main -I/usr/include/php7/TSRM -I/usr/include/php7/Zend -I/usr/include/php7/ext -I/usr/include/php7/ext/date/lib -DHAVE_CONFIG_H -g -O2 -c /usr/src/packages/BUILD/expect-0.3.3/expect.c -fPIC -DPIC -o .libs/expect.o [ 131s] /usr/src/packages/BUILD/expect-0.3.3/expect.c: In function 'OnSetExpectTimeout': [ 131s] /usr/src/packages/BUILD/expect-0.3.3/expect.c:95: warning: passing argument 1 of 'atoi' from incompatible pointer type [ 131s] /usr/src/packages/BUILD/expect-0.3.3/expect.c: In function 'OnSetExpectMatchMax': [ 131s] /usr/src/packages/BUILD/expect-0.3.3/expect.c:107: warning: passing argument 1 of 'atoi' from incompatible pointer type [ 131s] /usr/src/packages/BUILD/expect-0.3.3/expect.c: In function 'OnSetExpectLogUser': [ 131s] /usr/src/packages/BUILD/expect-0.3.3/expect.c:120: warning: passing argument 2 of 'strncasecmp' from incompatible pointer type [ 131s] /usr/src/packages/BUILD/expect-0.3.3/expect.c:121: warning: passing argument 2 of 'strncasecmp' from incompatible pointer type [ 131s] /usr/src/packages/BUILD/expect-0.3.3/expect.c:122: warning: passing argument 2 of 'strncasecmp' from incompatible pointer type [ 131s] /usr/src/packages/BUILD/expect-0.3.3/expect.c:123: warning: passing argument 2 of 'strncasecmp' from incompatible pointer type [ 131s] /usr/src/packages/BUILD/expect-0.3.3/expect.c: In function 'OnSetExpectLogFile': [ 131s] /usr/src/packages/BUILD/expect-0.3.3/expect.c:142: error: 'new_value_length' undeclared (first use in this function) [ 131s] /usr/src/packages/BUILD/expect-0.3.3/expect.c:142: error: (Each undeclared identifier is reported only once [ 131s] /usr/src/packages/BUILD/expect-0.3.3/expect.c:142: error: for each function it appears in.) [ 131s] /usr/src/packages/BUILD/expect-0.3.3/expect.c:143: warning: passing argument 1 of '_php_stream_open_wrapper_ex' from incompatible pointer type [ 131s] /usr/src/packages/BUILD/expect-0.3.3/expect.c: In function 'zif_expect_popen': [ 131s] /usr/src/packages/BUILD/expect-0.3.3/expect.c:257: error: incompatible types in assignment [ 131s] /usr/src/packages/BUILD/expect-0.3.3/expect.c: In function 'zif_expect_expectl': [ 131s] /usr/src/packages/BUILD/expect-0.3.3/expect.c:281: warning: passing argument 1 of 'zend_fetch_resource2_ex' from incompatible pointer type [ 131s] /usr/src/packages/BUILD/expect-0.3.3/expect.c:283: error: wrong type argument to unary exclamation mark [ 131s] /usr/src/packages/BUILD/expect-0.3.3/expect.c:298:74: error: macro "zend_hash_get_current_data" passed 2 arguments, but takes just 1 [ 131s] /usr/src/packages/BUILD/expect-0.3.3/expect.c:298: error: 'zend_hash_get_current_data' undeclared (first use in this function) [ 131s] /usr/src/packages/BUILD/expect-0.3.3/expect.c:301:63: error: macro "zend_hash_get_current_key" passed 4 arguments, but takes just 3 [ 131s] /usr/src/packages/BUILD/expect-0.3.3/expect.c:301: error: 'zend_hash_get_current_key' undeclared (first use in this function) [ 131s] /usr/src/packages/BUILD/expect-0.3.3/expect.c:313: warning: passing argument 1 of 'zend_hash_index_find' makes pointer from integer without a cast [ 131s] /usr/src/packages/BUILD/expect-0.3.3/expect.c:313: error: too many arguments to function 'zend_hash_index_find' [ 131s] /usr/src/packages/BUILD/expect-0.3.3/expect.c:323: warning: assignment makes pointer from integer without a cast [ 131s] /usr/src/packages/BUILD/expect-0.3.3/expect.c:326: warning: passing argument 1 of 'zend_hash_index_find' makes pointer from integer without a cast [ 131s] /usr/src/packages/BUILD/expect-0.3.3/expect.c:326: error: too many arguments to function 'zend_hash_index_find' [ 131s] /usr/src/packages/BUILD/expect-0.3.3/expect.c:334: warning: passing argument 1 of 'zend_hash_index_find' makes pointer from integer without a cast [ 131s] /usr/src/packages/BUILD/expect-0.3.3/expect.c:334: error: too many arguments to function 'zend_hash_index_find' [ 131s] /usr/src/packages/BUILD/expect-0.3.3/expect.c:367: error: too many arguments to function 'add_index_string' [ 131s] /usr/src/packages/BUILD/expect-0.3.3/expect.c:380: error: too many arguments to function 'add_next_index_string' [ 131s] /usr/src/packages/BUILD/expect-0.3.3/expect.c:388: error: too many arguments to function 'zend_hash_index_find' [ 131s] /usr/src/packages/BUILD/expect-0.3.3/expect.c:389: warning: passing argument 1 of 'zend_hash_index_find' makes pointer from integer without a cast [ 131s] /usr/src/packages/BUILD/expect-0.3.3/expect.c:389: error: too many arguments to function 'zend_hash_index_find' [ 131s] make: *** [expect.lo] Error 1