Обновление openssl на debian squeeze

Могу ли я заменить пакет openssl 0.9.8o-4squeeze16 на http://ftp.de.debian.org/debian/pool/main/o/openssl/openssl_1.0.1h-3_amd64.deb без проблем / сокетов? Я сделал apt-get update но я не получил более высокую версию, чем 0.9.8o-4squeeze16. Есть ли что-нибудь, о чем я должен подумать, прежде чем устанавливать его с помощью apt-get install openssl_1.0.1h-3_amd64.deb ?

Сжатие Debian больше не актуально, поэтому вы не можете ожидать, что для него будут доступны последние версии программ. Если вам действительно нужен инструмент командной строки openssl , вы можете перекомпилировать его, но подумайте, действительно ли вам это нужно: не так много новых функций. Есть еще обновления безопасности для сжатия, если это вас беспокоит.

Если у вас есть программа, скомпилированная с версией 1.0.x библиотеки OpenSSL, вы можете установить пакет libssl1.0.0 (наряду с пакетом libssl0.9.8 , который поставляется с дистрибутивом). Там нет официального бинарного файла, но загрузка источника из хрипоты или jessie и перекомпиляция пакета на машине сжатия должны работать.