Mint Cinnamon 18.3 64-разрядная проблема обновления

Когда я запускаю менеджер обновлений для Linux Mint Cinnamon 18.30, я получаю следующую ошибку и не знаю, как ее исправить.

E: gcc-6-base: 1.0989:package is in a very bad inconsistent state; you should reinstall it before attempting configuration E: libgcc1: 1.0989:dependency problems - leaving unconfigured E: libc6: 1.0989:dependency problems - leaving unconfigured E: liblzma5: 1.0989:dependency problems - leaving unconfigured E: libxau6: 1.0989:dependency problems - leaving unconfigured E: libxdmcp6: 1.0989:dependency problems - leaving unconfigured E: libxcb1: 1.0989:dependency problems - leaving unconfigured E: libx11-6: 1.0989:dependency problems - leaving unconfigured E: libxext6: 1.0989:dependency problems - leaving unconfigured E: libexif12: 1.0989:dependency problems - leaving unconfigured E: libjpeg-turbo8: 1.0989:dependency problems - leaving unconfigured E: liblcms2-2: 1.0989:dependency problems - leaving unconfigured E: libxdamage1: 1.0989:dependency problems - leaving unconfigured E: libxfixes3: 1.0989:dependency problems - leaving unconfigured E: libxshmfence1: 1.0989:dependency problems - leaving unconfigured E: libxxf86vm1: 1.0989:dependency problems - leaving unconfigured E: libasound2: 1.0989:dependency problems - leaving unconfigured E: libdrm2: 1.0989:dependency problems - leaving unconfigured E: libexpat1: 1.0989:dependency problems - leaving unconfigured E: libglapi-mesa: 1.0989:dependency problems - leaving unconfigured E: libx11-xcb1: 1.0989:dependency problems - leaving unconfigured E: libxcb-dri2-0: 1.0989:dependency problems - leaving unconfigured E: libxcb-dri3-0: 1.0989:dependency problems - leaving unconfigured E: libxcb-glx0: 1.0989:dependency problems - leaving unconfigured E: libxcb-present0: 1.0989:dependency problems - leaving unconfigured E: libxcb-sync1: 1.0989:dependency problems - leaving unconfigured E: libdrm-amdgpu1: 1.0989:dependency problems - leaving unconfigured E: zlib1g: 1.0989:dependency problems - leaving unconfigured E: libpciaccess0: 1.0989:dependency problems - leaving unconfigured E: libdrm-intel1: 1.0989:dependency problems - leaving unconfigured E: libdrm-nouveau2: 1.0989:dependency problems - leaving unconfigured E: libdrm-radeon1: 1.0989:dependency problems - leaving unconfigured E: libelf1: 1.0989:dependency problems - leaving unconfigured E: libbsd0: 1.0989:dependency problems - leaving unconfigured E: libtinfo5: 1.0989:dependency problems - leaving unconfigured E: libedit2: 1.0989:dependency problems - leaving unconfigured E: libffi6: 1.0989:dependency problems - leaving unconfigured E: libstdc++6: 1.0989:dependency problems - leaving unconfigured E: libllvm5.0: 1.0989:dependency problems - leaving unconfigured E: libsensors4: 1.0989:dependency problems - leaving unconfigured E: libgl1-mesa-dri: 1.0989:dependency problems - leaving unconfigured E: libgl1-mesa-glx: 1.0989:dependency problems - leaving unconfigured E: libglu1-mesa: 1.0989:dependency problems - leaving unconfigured E: libpng12-0: 1.0989:dependency problems - leaving unconfigured E: libfreetype6: 1.0989:dependency problems - leaving unconfigured E: libfontconfig1: 1.0989:dependency problems - leaving unconfigured E: libjpeg8: 1.0989:dependency problems - leaving unconfigured E: libjbig0: 1.0989:dependency problems - leaving unconfigured E: libtiff5: 1.0989:dependency problems - leaving unconfigured E: libvpx3: 1.0989:dependency problems - leaving unconfigured E: libxpm4: 1.0989:dependency problems - leaving unconfigured 

Как указано в первой строке

E: gcc-6-base: 1.0989: пакет находится в очень плохом несовместимом состоянии; вам следует переустановить его перед попыткой настройки

Вы должны переустановить этот пакет. Используйте код

 apt-cache search gcc 

затем

 apt-get update apt-get install g++-(version) c++-(version) 

Вы можете использовать любую версию (я рекомендую вам 4+). Если хранилище не найдено, воспользуйтесь этим и снова попробуйте перечисленные выше коды

 sudo add-apt-repository ppa:ubuntu-toolchain-r/test 

Запустите эти коды в вашем терминале

 sudo rm /var/lib/dpkg/info/mintinstall.postinst 

затем sudo apt install -f и прокомментируйте вывод