Articles of apt

Как безопасно выполнять большие # обновления пакетов в Debian Unstable?

Я использую Debian Unstable (sid) в течение нескольких месяцев. Единственная серьезная проблема, с которой я столкнулся, – это временная поломка Python3 во время обновления, и, к счастью, я смог исправить это в течение дня после того, как сопровождающие выпустили исправление. Тем не менее, я пытаюсь избежать таких проблем в будущем, и здесь я собираюсь спросить […]

Сбой команды apt, потому что нет имени файла для конфигурации клавиатуры: amd64

Я только что обновил мою установку Debian. После обновления моего sources.list с Jessie до Stretch я выполнил apt-get update apt-get upgrade , apt-get upgrade и apt-get dist-upgrade . Хотя некоторые пакеты не удалось обновить, компьютер все еще находится в рабочем состоянии. Однако 33 не удалось правильно установить, начиная с xserver-xorg-core . Сбой со следующим сообщением: […]

Попытка установить пакет Debian npm, заставляет apt-get удалить libssl-dev

:~/$ uname -a Linux hostname 4.9.0-4-rt-amd64 #1 SMP PREEMPT RT Debian 4.9.51-1 (2017-09-28) x86_64 GNU/Linux Я думаю, что у меня есть четкое дерево зависимостей без сломанных пакетов. :~/$ sudo apt-get check Reading package lists… Done Building dependency tree Reading state information… Done Однако когда я пытаюсь установить npm , apt-get хочет удалить libssl-dev : :~$ […]

VIM с поддержкой системного буфера обмена

я имею VIM – Vi IMproved 7.4 (2013 Aug 10, compiled Nov 24 2016 16:44:48) который был установлен с apt Он не поддерживает параметр clipboard . Поэтому я не могу скопировать некоторое содержимое буфера в системный буфер обмена, набрав, например, “+yy . Мне интересно, можно ли переключить мой VIM в другой repository, содержащий VIM с […]

Подпроцесс возвратил код ошибки, когда apt-get установил пакет

sudo apt-get install numactl E: Problem executing scripts APT::Update::Post-Invoke-Success ‘/usr/bin/test -e /usr/share/dbus-1/system-services/org.freedesktop.PackageKit.service && /usr/bin/test -S /var/run/dbus/system_bus_socket && /usr/bin/gdbus call –system –dest org.freedesktop.PackageKit –object-path /org/freedesktop/PackageKit –timeout 4 –method org.freedesktop.PackageKit.StateHasChanged cache-update > /dev/null; /bin/echo > /dev/null’ E: Sub-process returned an error code Как это исправить?

Debian / Ubuntu теперь не показывает ничего доступного для автоматического удаления после ошибки

Чтобы не затенять проблему с выходом, Я пытался побудить запустить autoremove Я запустил это. Это подвело. После чего ничто не показывает возможность автоматического удаления. Вещи все еще присутствуют, которые были в списке autoremove ? Я хотел бы повторить попытку autoremove . # sudo apt-get autoremove Reading package lists… Done Building dependency tree Reading state information… […]

Установка apt и deb на минимальной системе

У меня есть raspbian изображение motioneye установлено на Raspberry Pi . Он настолько минимален, что у него даже нет apt-get and deb . Я ничего не могу установить, я думаю, что ничего не скомпилируется и там. Существует множество образов raspbian и ubuntu с минимальной установкой, например ** openwrt *. такая же проблема есть. как мне […]

Обновление apt-get Debian 8, показывающее 404 Not Found

Я получаю следующий вывод каждый раз, когда запускаю apt-get update на моем Debian 8. Есть ли способ это исправить? Err http://ppa.launchpad.net jessie/main amd64 Packages 404 Not Found Ign http://ppa.launchpad.net jessie/main Translation-en Err http://ppa.launchpad.net jessie/main amd64 Packages 404 Not Found Ign http://ppa.launchpad.net jessie/main Translation-en Fetched 164 kB in 3s (47.0 kB/s) W: Failed to fetch http://ppa.launchpad.net/certbot/certbot/ubuntu/dists/jessie/main/binary-amd64/Packages […]

Ошибочно скачал какой-то repository Ubuntu в Debian. Как мне их удалить?

Я по ошибке скачал некоторое хранилище Ubuntu в Debian. Теперь, когда я пытаюсь обновить систему sudo apt-get update , мне это кажется: W: The repository ‘http://ppa.launchpad.net/webupd8team/y-ppa-manager/ubuntu cosmic Release’ does not have a Release file. N: Data from such a repository can’t be authenticated and is therefore potentially dangerous to use. N: See apt-secure(8) manpage for […]

apt-get update ничего не делает и не может открыть http-соединение

Я использую Debian Stretch. мое apt-get update работало нормально, но теперь оно пытается подключиться к сети, но ничего не происходит. Мой sources.list : deb http://deb.debian.org/debian stretch main contrib non-free deb-src http://deb.debian.org/debian stretch main contrib non-free deb http://deb.debian.org/debian stretch-updates main contrib non-free deb-src http://deb.debian.org/debian stretch-updates main contrib non- free deb http://security.debian.org/debian-security/ stretch/updates main contrib non-free deb-src […]