Проблема с установкой Gnome Debian

С помощью команды

sudo apt-get install gnome-core -f 

я получил

 The following packages have unmet dependencies: gnome-core : Depends: nautilus (>= 3.22) but it is not going to be installed Depends: gnome-sushi (>= 3.20) but it is not going to be installed E: Unable to correct problems, you have held broken packages. 

Поэтому я попробовал:

 sudo apt-get install nautilus -f 

Я получил:

 The following packages have unmet dependencies: nautilus : Depends: libnautilus-extension1a (= 3.22.3-1) but it is not going to be installed Recommends: gnome-sushi but it is not going to be installed E: Unable to correct problems, you have held broken packages. 

После того, как я попытался:

 sudo apt-get install gnome-sush -f 

Я получил:

 The following packages have unmet dependencies: gnome-sushi : Depends: nautilus (>= 3.2) but it is not going to be installed E: Unable to correct problems, you have held broken packages. 

Наконец я попробовал:

 sudo apt-get install libnautilus-extension1a -f 

И я получил:

 libnautilus-extension1a is already the newest version (1:3.14.2-0ubuntu9). 

Я также пытался очистить использование ( sudo отсутствует, потому что я был root):

 apt-get clean && apt-get update && apt-get upgrade -y && apt-get dist-upgrade -y 

source.list

deb http://http.kali.org/kali kali-roll main contrib non-free

deb http://security.debian.org/debian-security wheezy / updates main

deb http://ppa.launchpad.net/webupd8team/java/ubuntu trusty main

deb-src http://ppa.launchpad.net/webupd8team/java/ubuntu точный основной

Операционные системы

4.9.0-kali4-amd64 # 1 SMP Debian 4.9.25-1kali1 (2017-05-04) x86_64 GNU / Linux

Вы не используете Debian, но Kali . Затем по какой-то причине у вас есть этот пакет libnautilus-extension1a 1:3.14.2-0ubuntu9.1 от Ubuntu Vivid, в то время как Kali- 3.22.3-1 (& Stretch) имеет 3.22.3-1 .

Вы можете использовать

 sudo dpkg --remove --force-remove-reinstreq --force-hold libnautilus-extension1a 

чтобы удалить его. От man dpkg :

hold Пакет, помеченный как приостановленный, не обрабатывается dpkg, если только это не принудительно сделать с опцией --force-hold .

rest-required Требуется переустановленный пакет, требующий повторной установки. Эти пакеты не могут быть удалены, если не принудительно с опцией --force-remove-reinstreq .

Затем вы можете sudo apt-get update и попытаться переустановить его из ваших обычных источников.

У вас есть сломанные пакеты, потому что у вас есть смешанные sources.list : debian wheezy, ubuntu trusty, exact и kali roll

Измените sources.list , сохраните только следующую строку:

 deb http://http.kali.org/kali kali-rolling main contrib non-free 

Обновите свой пакет

 apt-get update apt-get upgrade apt-get dist-upgrade apt-get -f install 

Затем установите рабочий стол gnome:

 apt-get install gnome-core kali-defaults kali-root-login desktop-base