Intereting Posts
Одиночное DRM Удаление для личного использования x11 – не может перемещать курсор мыши с нуворишем, xev все еще сообщает движение Завершение бафа для `unrar` Адаптер Wi-Fi не найден, я все еще использую Wi-Fi. Моя настройка «Проводная» подключена, но у меня нет сетевого шнура специальные каталоги rsync Xvfb не освобождает память Проблемы с Python в CentOS – ошибка загрузки общих библиотек – libpython2.7.so.1.0 Не удается rsync: сбой записи – на устройстве нет места (28) Загрузите 32-разрядную ОС из 64-разрядного GRUB2 Как подключить пример журнала сообщения вручную к logstash для обработки Как xrandr определяет / выбирает, какие разрешения предложить? Как предотвратить прекращение работы Anacron после начала работы от батареи? Сканирующая пленка (негативы) в Linux Не удалось получить файл выпуска при запуске debootstrap с sudo Отображение даты пакета в интерфейсе Aptitude

Как установить dia на мой debian8 64 процессора?

dpkg --add-architecture i386 root@hws:/home/debian8# dpkg -i /home/debian8/Downloads/dia_0.97.2-5_i386.deb Selecting previously unselected package dia. (Reading database ... 87794 files and directories currently installed.) Preparing to unpack .../dia_0.97.2-5_i386.deb ... Unpacking dia (0.97.2-5) ... dpkg: dependency problems prevent configuration of dia: dia depends on libc6 (>= 2.7). dia depends on libcairo2 (>= 1.2.4). dia depends on libfreetype6 (>= 2.2.1). dia depends on libgdk-pixbuf2.0-0 (>= 2.22.0). dia depends on libglib2.0-0 (>= 2.24.0). dia depends on libgtk2.0-0 (>= 2.12.0). dia depends on libpango1.0-0 (>= 1.18.0). dia depends on libpng12-0 (>= 1.2.13-4). dia depends on libxml2 (>= 2.7.4). dia depends on dia-common (= 0.97.2-5). dia depends on dia-libs (= 0.97.2-5). dpkg: error processing package dia (--install): dependency problems - leaving unconfigured Processing triggers for mime-support (3.58) ... Errors were encountered while processing: dia root@hws:/home/debian8# apt-get install -y libc6 Reading package lists... Done Building dependency tree Reading state information... Done libc6 is already the newest version. You might want to run 'apt-get -f install' to correct these: The following packages have unmet dependencies: dia:i386 : Depends: libc6:i386 (>= 2.7) but it is not installable Depends: libcairo2:i386 (>= 1.2.4) but it is not installable Depends: libfreetype6:i386 (>= 2.2.1) but it is not installable Depends: libgdk-pixbuf2.0-0:i386 (>= 2.22.0) but it is not installable Depends: libglib2.0-0:i386 (>= 2.24.0) but it is not installable Depends: libgtk2.0-0:i386 (>= 2.12.0) but it is not installable Depends: libpango1.0-0:i386 (>= 1.18.0) but it is not installable Depends: libpng12-0:i386 (>= 1.2.13-4) but it is not installable Depends: libxml2:i386 (>= 2.7.4) but it is not installable Depends: dia-common:i386 (= 0.97.2-5) but it is not installable Depends: dia-libs:i386 (= 0.97.2-5) but it is not installable Recommends: gsfonts-x11:i386 but it is not installable E: Unmet dependencies. Try 'apt-get -f install' with no packages (or specify a solution). root@hws:/home/debian8# apt-get -f install Reading package lists... Done Building dependency tree Reading state information... Done Correcting dependencies... Done The following packages will be REMOVED: dia:i386 0 upgraded, 0 newly installed, 1 to remove and 22 not upgraded. 1 not fully installed or removed. After this operation, 592 kB disk space will be freed. Do you want to continue? [Y/n] y (Reading database ... 87802 files and directories currently installed.) Removing dia (0.97.2-5) ... Processing triggers for mime-support (3.58) ... root@hws:/home/debian8# apt-get install -y libc6:i386 Reading package lists... Done Building dependency tree Reading state information... Done Package libc6:i386 is not available, but is referred to by another package. This may mean that the package is missing, has been obsoleted, or is only available from another source 

Для установки пакета dia 32 deb бесполезно использовать dpkg --add-architecture i386 . Как установить его на моем 64-разрядном процессоре debian8?

Привет, верно, что в пакете загрузки отсутствует пакет amd: 64 deb
[url] http://sourceforge.net/projects/dia-installer/files/latest/download?source=top3_dlp_t5[/url]

введите описание изображения здесь

Я устанавливаю его с apt-get install dia на моем 64-битном debian, думаю, что это Oaima.

Используйте репозитории и не пытайтесь устанавливать пакеты с неправильной архитектурой и зависимостями.

 aptitude purge dia apt-get update apt-get install dia