Yum возвращает ошибки при использовании

Когда я пытаюсь использовать Yum (например, # yum update ), я получаю сообщение об ошибке, и это мешает мне использовать Yum. Любая помощь в этом будет действительно крутой!

Это ошибка, которую я получаю, когда пытаюсь запустить команду Yum:

 # yum update Setting up Update Process Setting up repositories not using ftp, http[s], or file for repos, skipping - 4 is not a valid release or hasnt been released yet Cannot find a valid baseurl for repo: update Error: Cannot find a valid baseurl for repo: update 

Вот содержание файла CentOS-Base.repo :

 [base] name=CentOS-$releasever - Base mirrorlist=http://mirrorlist.centos.org/?release=$releasever&arch=$basearch&repo=os #baseurl=http://mirror.centos.org/centos/$releasever/os/$basearch/ gpgcheck=1 gpgkey=http://mirror.centos.org/centos/RPM-GPG-KEY-centos4 protect=1 #released updates [update] name=CentOS-$releasever - Updates mirrorlist=http://mirrorlist.centos.org/?release=$releasever&arch=$basearch&repo=updates #baseurl=http://mirror.centos.org/centos/$releasever/updates/$basearch/ gpgcheck=1 gpgkey=http://mirror.centos.org/centos/RPM-GPG-KEY-centos4 protect=1 #packages used/produced in the build but not released [addons] name=CentOS-$releasever - Addons mirrorlist=http://mirrorlist.centos.org/?release=$releasever&arch=$basearch&repo=addons #baseurl=http://mirror.centos.org/centos/$releasever/addons/$basearch/ gpgcheck=1 gpgkey=http://mirror.centos.org/centos/RPM-GPG-KEY-centos4 protect=0 #additional packages that may be useful [extras] name=CentOS-$releasever - Extras mirrorlist=http://mirrorlist.centos.org/?release=$releasever&arch=$basearch&repo=extras #baseurl=http://mirror.centos.org/centos/$releasever/extras/$basearch/ gpgcheck=1 gpgkey=http://mirror.centos.org/centos/RPM-GPG-KEY-centos4 protect=0 #additional packages that extend functionality of existing packages [centosplus] name=CentOS-$releasever - Plus mirrorlist=http://mirrorlist.centos.org/?release=$releasever&arch=$basearch&repo=centosplus #baseurl=http://mirror.centos.org/centos/$releasever/centosplus/$basearch/ gpgcheck=1 enabled=0 gpgkey=http://mirror.centos.org/centos/RPM-GPG-KEY-centos4 protect=0 #contrib - packages by Centos Users [contrib] name=CentOS-$releasever - Contrib mirrorlist=http://mirrorlist.centos.org/?release=$releasever&arch=$basearch&repo=contrib #baseurl=http://mirror.centos.org/centos/$releasever/contrib/$basearch/ gpgcheck=1 enabled=0 gpgkey=http://mirror.centos.org/centos/RPM-GPG-KEY-centos4 protect=0 

Заранее спасибо! Макс Кулик

3 Solutions collect form web for “Yum возвращает ошибки при использовании”

Вы можете сделать следующее:

  1. Откройте /etc/yum.repos.d/CentOS-Base.repo в редакторе
  2. Прокомментируйте записи «зеркального списка».
  3. Раскомментируйте записи «baseurl» и измените их на

     http://vault.centos.org/4.9/os/$basearch 

Или лучше, прекратите использование неподдерживаемых ОС.

Пожалуйста, дайте нам знать файлы .repo внутри вашего /etc/yum.repos.d/

пытаться

grep -iRl update /etc/yum.repos.d/

И найдите экземпляры обновления внутри файла .repo. вероятно, вам нужно положить

включить = 0

Для раздела файла репо "обновления"

В противном случае попробуйте открыть каждый файл .repo, который у вас есть внутри /etc/yum.repos.d/, и проверьте раздел «Обновление» в разделе репо, и если вы заметили что-либо, попробуйте отключить его, поставив 0 для включения строки.

Сообщите нам, если бы это сработало для вас

Тот же вопрос,

 #rpm -q centos-release centos-release-4-4.3 

Попробуйте изменить /etc/yum.repos.d/CentOS-Base.repo следующим образом: http://vault.centos.org/4.8/CentOS-Base.repo

Это работает для меня.

  • Как сделать пакет rpm, который устанавливает среду Java, если необходимо
  • Как узнать, безопасен ли пакет для обновления в CentOS?
  • Обрезка дерева пакетов с помощью apt-get и yum
  • Можно ли использовать CentOS CBS в качестве базового репозитория yum?
  • Самый безобидный пакет для установки для тестирования yum?
  • Устранение недостающих зависимостей пакета при попытке установить октаву
  • Какие менеджеры пакетов используют популярные дистрибутивы Unix?
  • Установка `setfacl` в Cent OS 6
  • yum: Как я могу проинструктировать yum установить определенную версию для X
  • pdksh отсутствует в RHEL 6 и CentOS 6?
  • почему мой рабочий стол по-прежнему действует так же, как Fedora 20, даже после перехода на Fedora 21?
  • Interesting Posts

    Boot Mint с USB-вспышки на macmini3,1 (с установленным rEFInd)

    Как использовать fail2ban для запрета всех запросов php и cgi-bin

    dig не разрешает неквалифицированные доменные имена, но nslookup делает

    Любое приложение для воспроизведения песни при вставке гарнитуры

    Первичный и логический раздел

    Утилита командной строки для получения пароля, у которого нет отклика эха

    Bash for loop создает папки; мне нужно избегать некоторых символов?

    Получите Sudoers через LDAP. (SUSE Linux Enterprise Server 12)

    GUI работает без определения $ XAUTHORITY, но не для root

    Можно ли изменить цвета шрифтов в терминале, не влияя на формат отпечатка «% * s» printf?

    Проблема маршрутизации через 2-х хоп в локальной сети

    Как я могу применить фильтры procmail к почтовому ящику maildir?

    Как печатать нажатия клавиш в формате .inputrc?

    В HP-UX, как я могу записывать сообщения системных событий Information Only Only в syslog.log?

    Как я могу получить версию vsftpd в переменной оболочки?

    Linux и Unix - лучшая ОС в мире.