Библиотека заявок Yum установлена, но это не

Я пытаюсь скомпилировать программу с помощью cmake, которая имеет зависимость от libQtWebKit_debug.so. Согласно yum обеспечивает , эта библиотека должна находиться в / usr / lib64 /, но ее нет:

yum provides */libQtWebKit_debug.so Loaded plugins: langpacks, refresh-packagekit 1:qt-devel-4.8.5-10.fc20.i686 : Development files for the Qt toolkit Repo : fedora Matched from: Filename : /usr/lib/libQtWebKit_debug.so 1:qt-devel-4.8.5-10.fc20.x86_64 : Development files for the Qt toolkit Repo : fedora Matched from: Filename : /usr/lib64/libQtWebKit_debug.so 

Повторная установка соответствующего пакета ( qt-devel ) не помогла: yum удалить qt-devel , затем yum install qt-devel .

Ты прав. Кажется, что есть некоторые изменения, которые упали файл /usr/lib64/libQtWebKit_debug.so из пакета qt-devel когда-то после версии qt-devel-4.8.6- 13 .fc21.x86_64 (<- есть этот файл) по сравнению с qt-devel -4.8.6- 18 .fc21.x86_64 (<- не имеет этого файла).

Взгляд в журнал изменений 1168259 – qt-devel содержит некоторые компоненты веб-кита, которые, вероятно, не должны были быть включены , по-видимому, являются причиной:

 # rpm -q qt-devel --changelog | head -n 16 * Wed Nov 26 2014 Rex Dieter <rdieter@fedoraproject.org> 1:4.8.6-18 - omit previously-overlooked webkit bits (#1168259) * Sun Nov 09 2014 Rex Dieter <rdieter@fedoraproject.org> 1:4.8.6-17 - Broken qmake_qt4 in /usr/lib/rpm/macros.d/macros.qt4 (#1161927) * Mon Nov 03 2014 Rex Dieter <rdieter@fedoraproject.org> 1:4.8.6-16 - macros.qt4: standalone, improved %qmake_qt4 macro (sync'd with qt5 version) * Sat Nov 01 2014 Kevin Kofler <Kevin@tigcc.ticalc.org> - 1:4.8.6-15 - sync system-clucene patch from qt5-qttools (some QDir::mkpath in QtCLucene) * Sun Oct 26 2014 Kevin Kofler <Kevin@tigcc.ticalc.org> - 1:4.8.6-14 - build against the system clucene09-core (same patch as for qt5-qttools) * Tue Sep 16 2014 Rex Dieter <rdieter@fedoraproject.org> - 1:4.8.6-13 

Поэтому я бы попросил в bugreport или упомянуть об этом факте автору программного обеспечения, которое вы пытаетесь скомпилировать.