Сервер Xorg не запускается

У меня возникли трудности с запуском сервера Xorg в моей установке Gentoo. Я установил его через HOWTO для конфигурации сервера X. Когда я добираюсь до той части, где я startx , экран немного мерцает, а затем он возвращает меня обратно в терминал со следующим сообщением:

 [some stuff here] (EE) Failed to load module "vesa" (module does not exist, 0) (EE) Failed to load module "fbdev" (module does not exist, 0) FATAL: COuld not load /lib/modules/2.6.35-gentoo-r12/modules.dep: No such file or directory 

Две вещи, которые мне странны, – я не использую драйверы vesa или fbdev. Я использую intel и evdev в своем /etc/make.conf . Во-вторых, я не использую модули в своем ядре. Я специально удаляю их. Это не вызвало проблемы раньше. Я не совсем уверен, что происходит.

Я использую intel и evdev в своем /etc/make.conf

Это означает, что xorg будет скомпилирован с поддержкой intel и evdev 🙂
Xorg не читает ваш make.conf, он пытается угадать ваше оборудование, если нет xorg.conf, и похоже, что он не может угадать ваше оборудование.

emerge sys-apps/lshw sys-apps/pciutils
и ищите НЕЗАВИСИМЫЕ и ОТКЛЮЧЕННЫЕ устройства в выходе lshw . lspci также может быть полезен.

Попробуйте запустить:

 X -configure 

Затем настройте (поставьте правильный драйвер в нужное место), он выводит ~/xorg.conf.new и использует его как ваш xorg.conf

Я вообще не использую модульное ядро

В этом случае это не имеет значения , но это означает, что вы не можете загружать модуль с параметрами, что иногда полезно.

FATAL: Не удалось загрузить /lib/modules/2.6.35-gentoo-r12/modules.dep: нет такого файла или каталога

Убедитесь, что вы запустили make modules_install для своего ядра.