Intereting Posts
Добавление сертификата nssdb из сценария установки Как загрузить все файлы, связанные с веб-сайтом с помощью wget Ноутбук падает на видеодрайвер Vesa Зачем нужен еще один блок IPv6? Используйте find, чтобы найти определенный каталог и удалить все файлы, кроме одного каталога Невозможно установить Flash-плеер после добавления несвободных репозиториев Как запланировать запуск сценария оболочки, который открывает Firefox Почему некоторые приложения не поддерживают терминал после запуска Что такое непривилегированный контейнер LXC? Копировать выбранные файлы итеративно по SSH Проблемы с установкой Ruby без sudo Как я могу использовать Synergy при подключении через разные маршрутизаторы? Продвинутое программирование в Unix Envinronment 3rd, 4.21, я хочу, как rmdir обрабатывает количество ссылок Использование sed, как форматировать одно слово в строке, удаляя пустое пространство Как я могу предоставить все разрешения для файла для одного пользователя, а не я?

Что означает это сообщение из ядра?

Когда я запускаю VirtualBox, я получил предупреждение: VirtualBox' uses 32-bit capabilities (legacy support in use)

Это кажется безобидным, хотя, но я все еще хотел бы знать, что это значит? И почему я это понял?

Я запускаю 64-битный Arch Linux с Intel VT (процессор i5), VT enabled .

Проверяя 32-битные файлы в / usr / lib / virtualbox, я получил:

 %> find . -type f -exec is32elf {} \; ./VBoxDD2GC.gc ./VMMGC.gc ./VBoxDDGC.gc ./ExtensionPacks/Oracle_VM_VirtualBox_Extension_Pack/linux.amd64/VBoxEhciRC.rc ./ExtensionPacks/Oracle_VM_VirtualBox_Extension_Pack/linux.x86/VBoxPuelMain.so ./ExtensionPacks/Oracle_VM_VirtualBox_Extension_Pack/linux.x86/VBoxEhciR0.r0 ./ExtensionPacks/Oracle_VM_VirtualBox_Extension_Pack/linux.x86/VBoxPciRawR0.r0 ./ExtensionPacks/Oracle_VM_VirtualBox_Extension_Pack/linux.x86/VBoxVRDP.so ./ExtensionPacks/Oracle_VM_VirtualBox_Extension_Pack/linux.x86/VBoxEhciRC.rc ./ExtensionPacks/Oracle_VM_VirtualBox_Extension_Pack/linux.x86/VBoxEhciR3.so ./ExtensionPacks/Oracle_VM_VirtualBox_Extension_Pack/linux.x86/VBoxPciRawDrv.so ./ExtensionPacks/Oracle_VM_VirtualBox_Extension_Pack/linux.x86/VBoxUsbCardReaderR3.so ./ExtensionPacks/Oracle_VM_VirtualBox_Extension_Pack/linux.x86/VBoxPciRawR3.so ./ExtensionPacks/Oracle_VM_VirtualBox_Extension_Pack/solaris.x86/VBoxPuelMain.so ./ExtensionPacks/Oracle_VM_VirtualBox_Extension_Pack/solaris.x86/VBoxEhciR0.r0 ./ExtensionPacks/Oracle_VM_VirtualBox_Extension_Pack/solaris.x86/VBoxVRDP.so ./ExtensionPacks/Oracle_VM_VirtualBox_Extension_Pack/solaris.x86/VBoxEhciRC.rc ./ExtensionPacks/Oracle_VM_VirtualBox_Extension_Pack/solaris.x86/VBoxEhciR3.so ./ExtensionPacks/Oracle_VM_VirtualBox_Extension_Pack/solaris.x86/VBoxUsbCardReaderR3.so ./ExtensionPacks/Oracle_VM_VirtualBox_Extension_Pack/solaris.amd64/VBoxEhciRC.rc 

Может быть, это может что-то объяснить?

Это просто означает, что виртуальный бокс использует старый API возможностей Linux . Он устарел, но по-прежнему поддерживается, и появляется предупреждение о том, чтобы разработчики виртуальных боксов могли двигаться дальше и использовать новый.