Как я могу запускать свои собственные скрипты в kate 3.8.2? «Внешние инструменты» недоступны в разделе плагинов

Я использую Kubuntu 12.04 LTS. Как я могу запускать свои собственные скрипты в kate 3.8.2?

Похоже, что плагин с именем External tools больше недоступен.

Я хотел бы запускать сценарии Python или оболочки в kate и вызывать их с помощью сочетания клавиш, например F4 .

В качестве примера этот простой скрипт идеально изменился бы на конкретное окно, когда я нажму F4 .

 #!\bin\sh wmctrl -a "<Window name>" 

К сожалению, в настоящее время для этого плагина нет поддерживающего.

Тем не менее, есть много популярных редакторов, которые так или иначе поддерживают это. Помимо обычных подозреваемых ((g) VIM, EMACS) SciTE имеет довольно хорошую поддержку внешних скриптов, я бы сказал.

И есть Acme , совершенно уникально интегрированная со сценариями, переадресацией труб и т. Д., Без синтаксической раскраски и тому подобное, которое вы, вероятно, ожидаете от современного редактора.

В KATE 3.8.5 есть Build Plugin . Он добавит меню «Сборка» и «Конфигурация сборки» (посмотрите внизу слева, рядом с терминалом). Если вы откроете конфигурацию сборки, установите вкладку Target Settings и вы можете установить команды в «Build», «Clean» и «Quick compile». Вы можете настроить и короткую клавишу для этих команд.

PS Это работает только в том случае, если у вас есть до 3 разных сценариев / команд, которые необходимо выполнить