Ошибки набора номера Wvdial.conf. Модель малины Pi B Модем Huawei E1820 3G

Linux пинает мою задницу. Я попытался использовать wvdial в первый раз, чтобы заставить 3G работать над моей малиной Pi, но все пошло не так, как ожидалось. Прежде всего, когда я делаю простой

 sudo wvdialconf 

В результате сканирования появляется следующее сообщение:

введите описание изображения здесь

ОК. Наверное, не лучшее начало, которое я могу получить из-за ошибок на линиях:

 ttyUSB0<*1>: ATQ0 V1 E1 S0=0 -- ERROR ttyUSB0<*1>: ATQ0 V1 E1 &C1 -- ERROR ttyUSB0<*1>: ATQ0 V1 E1 &D2 -- ERROR 

Я полагал, что эти ошибки, вероятно, могут быть причиной неудачи моей более поздней попытки использовать wvdial , что дает мне результат как таковой:

 --> WvDial: Internet dialer version 1.61 --> Initializing modem. --> Sending: ATZ ATZ OK --> Sending: ATQ0 V1 E1 +FCLASS=0 ATQ0 V1 E1 +FCLASS=0 OK --> Sending: AT+CGDCONT=1, "IP", "internet" AT+CGDCONT=1, "IP", "internet" ERROR --> Bad init string. --> Initializing modem. --> Sending: ATZ ATZ OK --> Sending: ATQ0 V1 E1 +FCLASS=0 ATQ0 V1 E1 +FCLASS=0 OK --> Sending: AT+CGDCONT=1, "IP", "internet" AT+CGDCONT=1, "IP", "internet" ERROR --> Bad init string. --> Initializing modem. --> Sending: ATZ ATZ OK --> Sending: ATQ0 V1 E1 +FCLASS=0 ATQ0 V1 E1 +FCLASS=0 OK --> Sending: AT+CGDCONT=1, "IP", "internet" AT+CGDCONT=1, "IP", "internet" ERROR --> Bad init string. 

Чтобы предоставить некоторые сведения о моих конфигурациях: Мой wvdial.conf выглядит так:

 [Dialer Defaults] Init1 = ATZ Init2 = ATQ0 V1 E1 +FCLASS=0 Modem Type = Analog Modem ISDN = 0 New PPPD = yes Phone = *99# Modem = /dev/ttyUSB0 Username = username Password = password Baud = 9600 [Dialer E1820] Init1 = ATZ Init2 = ATQ0 V1 E1 +FCLASS=0 Init3 = AT+CGDCONT=1, "IP", "internet" Stupid Mode = 1 Phone = *99# New PPPD = yes Modem = /dev/ttyUSB0 Username = username Carrier Check = no Password = password Baud = 9600 

и мои журналы dmesg выглядят как таковые: введите описание изображения здесь

Из этих выводов я делаю вывод (или, возможно, ошибочно полагаю), что мой Huawei E1820 действительно превратился в модем и готов к wvdial dialing.

Дополнительная информация:
SIM-карта, которую я использую, отключена от SIM_PIN и куплена у Chunghwa Telecom, крупной телекоммуникационной компании, расположенной на Тайване.

Обновлено Привет всем, я попытался изменить мои конфиги в файле /etc/wvdial.conf и теперь он выглядит следующим образом:

 [Dialer E1820] Init1 = ATZ Init2 = ATQ0 V1 E1 +FCLASS=0 Stupid Mode = 1 Modem Type = Analog Modem ISDN = 0 Phone = *99# New PPPD = yes Modem = /dev/gsmmodem Baud = 460800 Username = username Carrier Check = no Password = password 

Теперь, когда я запускаю wvdial , я получаю такую ​​ошибку:

 --> WvDial: Internet dialer version 1.61 --> Initializing modem. --> Sending: ATZ ATZ OK --> Sending: ATQ0 V1 E1 +FCLASS=0 ATQ 0 V1 E1 +FCLASS=0 OK --> Modem initialized. --> Sending: ATD*99# --> Waiting for carrier. ATD*99# ERROR --> Invalid dial command. --> Disconnecting at Sat Aug 20 08:53:35 2016 

Я подозреваю, что причина этого заключается в следующем:

  • модем работает не так, как ожидалось, или
  • параметр Phone в файле /etc/wvdial.conf неправильно назначен.

Надеюсь, у меня это получится. Есть идеи?