Модернизация Wheezy -> Jessie Не удалось установить procps

Я пытаюсь обновить Debian Wheezy до Jessie, но он не удался во время apt-get dist-upgrade , и теперь я полностью заполнен.

Вот что происходит, когда я пытаюсь apt-get dist-upgrade :

  sudo apt-get dist-upgrade Reading package lists... Done Building dependency tree Reading state information... Done Calculating upgrade... Done The following packages will be REMOVED: libgnutls-dev libgvc5 libkadm5srv-mit8 librtmp-dev ruby-actionmailer-2.3 ruby-actionpack-2.3 ruby-activerecord-2.3 ruby-activeresource-2.3 ruby-rails-2.3 The following NEW packages will be installed: cpp-4.8 emacsen-common firmware-linux-free fonts-dejavu-extra gcc-4.8 gcc-4.8-base guile-2.0-libs icu-devtools imagemagick-6.q16 init iproute2 irqbalance libasan0 libasound2-data libasprintf-dev libatm1 libb-hooks-op-check-perl libbareword-filehandles-perl libbind9-90 libboost-iostreams1.55.0 libcap-ng0 libcdt5 libcgraph6 libclass-method-modifiers-perl libcupsfilters1 libdebconfclient0 libdevel-globaldestruction-perl libdns-export100 libdns100 libdrm-nouveau2 libefivar0 libestr0 libexiv2-13 libfakeroot libfftw3-double3 libfl-dev libgcc-4.8-dev libgcrypt20-dev libgettextpo-dev libgmp-dev libgmpxx4ldbl libgnutls-deb0-28 libgnutlsxx28 libgraphite2-3 libgvc6 libgvpr2 libharfbuzz0b libhogweed2 libhtml-form-perl libhtml-format-perl libhtml-parser-perl libhtml-tree-perl libhttp-cookies-perl libhttp-daemon-perl libhttp-message-perl libhttp-negotiate-perl libimport-into-perl libindirect-perl libintl-perl libio-html-perl libirs-export91 libisc-export95 libisc95 libisccc90 libisccfg-export90 libisccfg90 libjs-excanvas libkadm5clnt-mit9 libkadm5srv-mit9 libkdb5-7 libkyotocabinet16 liblexical-sealrequirehints-perl libllvm3.5 liblogging-stdlog0 liblognorm1 liblwp-protocol-https-perl liblwres90 libmagickcore-6.q16-2 libmagickcore-6.q16-2-extra libmagickwand-6.q16-2 libmoo-perl libmspack0 libmultidimensional-perl libnet-http-perl libnet-smtp-ssl-perl libnettle4 libnuma1 libpango-1.0-0 libpangocairo-1.0-0 libpangoft2-1.0-0 libpangox-1.0-0 libpangoxft-1.0-0 libpsl0 libpython-stdlib libpython2.7-minimal libpython2.7-stdlib librole-tiny-perl librtmp1 libsasl2-modules-db libsctp1 libstrictures-perl libsub-exporter-progressive-perl libtasn1-6 libtcl8.5 libtext-unidecode-perl libtxc-dxtn-s2tc0 libwebp5 libwebpdemux1 libwebpmux1 libwww-perl libxcb-dri2-0 libxcb-dri3-0 libxcb-present0 libxcb-sync1 libxml-libxml-perl libxml-namespacesupport-perl libxml-parser-perl libxml-sax-base-perl libxml-sax-expat-perl libxml-sax-perl libxshmfence1 libxtables10 linux-compiler-gcc-4.8-x86 linux-headers-3.16.0-4-amd64 linux-headers-3.16.0-4-common linux-image-3.16.0-4-amd64 linux-kbuild-3.16 lksctp-tools nettle-dev openjdk-7-jre-headless openssh-sftp-server python-defusedxml python-pil python-pyinotify python-six python-wstools qtcore4-l10n ruby ruby-activesupport ruby-atomic ruby-minitest ruby-net-http-persistent ruby-thor ruby-thread-safe ruby2.1 ruby2.1-dev systemd-sysv zsh-common The following packages have been kept back: db5.1-util The following packages will be upgraded: ack-grep acpid apt apt-utils aptitude aptitude-common at avahi-daemon base-passwd bind9 bind9-host bind9utils bsdutils build-essential bundler cabextract clamav-base cron curl dbus default-jre-headless dictionaries-common dmsetup dnsutils docutils-common dovecot-core dovecot-imapd dovecot-mysql dovecot-pop3d dovecot-sieve dselect efibootmgr fail2ban fakeroot fcgiwrap flex gettext ghostscript gir1.2-freedesktop gir1.2-gdkpixbuf-2.0 gir1.2-glib-2.0 gir1.2-rsvg-2.0 imagemagick imagemagick-common iproute iptables iputils-ping isc-dhcp-client isc-dhcp-common krb5-multidev libapt-pkg4.12 libasound2 libasprintf0c2 libatk-wrapper-java-jni libatk1.0-0 libatk1.0-data libcairo-gobject2 libcairo-script-interpreter2 libcairo2 libclamav7 libclass-accessor-grouped-perl libcryptsetup4 libcups2 libcupsimage2 libcurl3 libcurl3-gnutls libcurl4-gnutls-dev libcwidget3 libdevmapper1.02.1 libdjvulibre-dev libdjvulibre21 libept1.4.12 libffi-dev libgcrypt11-dev libgdk-pixbuf2.0-0 libgdk-pixbuf2.0-common libgettextpo0 libgirepository-1.0-1 libgl1-mesa-dri libgl1-mesa-glx libglapi-mesa libgnutls-openssl27 libgraphviz-dev libgs9 libgs9-common libgssapi-krb5-2 libgssrpc4 libgtk2.0-0 libgtk2.0-bin libicu-dev libio-socket-ssl-perl libjasper-dev libjasper1 libjson0 libk5crypto3 libkrb5-3 libkrb5-dev libkrb5support0 libldap-2.4-2 libldap2-dev libmailtools-perl libmailutils4 libmng1 libnetpbm10 libopenexr-dev libopenexr6 libp11-kit-dev libp11-kit0 libpam-modules libpam-modules-bin libpam0g libpango1.0-0 libpaper1 libpathplan4 libpulse0 libpython2.7 libqt4-network libqt4-opengl libqt4-xml libqtcore4 libqtdbus4 libqtgui4 librsvg2-2 librsvg2-common libruby libsasl2-2 libsemanage-common libsemanage1 libsnmp-base libsql-abstract-perl libssh2-1 libssh2-1-dev libsystemd-journal0 libusb-1.0-0 libvncserver0 libwmf-dev libwmf0.2-7 libxapian22 libxdot4 libxft2 libxslt1-dev libxslt1.1 linux-headers-amd64 linux-image-amd64 login lynx lynx-cur mailutils mailutils-common memcached mercurial mercurial-common netpbm openbsd-inetd openssh-client openssh-server passwd postfix postfix-mysql procps pslib1 python python-apt python-chardet python-debian python-docutils python-imaging python-minimal python-pkg-resources python-pygments python-reportbug python-soappy python2.7 python2.7-minimal reportbug rsyslog ruby-activesupport-2.3 ruby-dev ruby-ffi ruby-json ruby-mysql ruby-tzinfo shared-mime-info sudo sysvinit tcl8.5 texinfo ttf-dejavu-extra ufraw-batch webalizer wget zsh zsh-doc 193 upgraded, 148 newly installed, 9 to remove and 1 not upgraded. 6 not fully installed or removed. Need to get 914 kB/213 MB of archives. After this operation, 309 MB of additional disk space will be used. Do you want to continue [Y/n]? Y Get:1 http://ftp.cn.debian.org/debian/ jessie/main librtmp1 amd64 2.4+20150115.gita107cef-1 [59.8 kB] Get:2 http://ftp.cn.debian.org/debian/ jessie/main libgnutlsxx28 amd64 3.3.8-6+deb8u3 [14.6 kB] Get:3 http://ftp.cn.debian.org/debian/ jessie/main nettle-dev amd64 2.7.1-5+deb8u1 [839 kB] Fetched 914 kB in 1s (566 kB/s) Reading changelogs... Done Extracting templates from packages: 100% Preconfiguring packages ... dpkg: warning: files list file for package 'postgresql-client-common' missing; assuming package has no files currently installed dpkg: warning: files list file for package 'postgresql-client-9.1' missing; assuming package has no files currently installed (Reading database ... 80932 files and directories currently installed.) Preparing to unpack .../procps_2%3a3.3.9-9_amd64.deb ... Failed to parse message: No such device or address 

Apt будет запасать в Failes to parse message... и я должен убить процесс:

 ✘ erwan@gm  ~  ps aux | grep apt root 16356 0.0 0.0 55096 2008 pts/3 S+ 10:33 0:00 sudo apt-get dist-upgrade root 16357 0.1 0.6 85804 49696 pts/3 S+ 10:33 0:00 apt-get dist-upgrade root 18562 0.0 0.2 42436 20264 pts/18 Ss+ 10:33 0:00 /usr/bin/dpkg --status-fd 36 --unpack --auto-deconfigure /var/cache/apt/archives/procps_2%3a3.3.9-9_amd64.deb erwan 18804 0.0 0.0 12720 1012 pts/15 S+ 10:42 0:00 grep --color=auto --exclude-dir=.bzr --exclude-dir=CVS --exclude-dir=.git --exclude-dir=.hg --exclude-dir=.svn apt erwan@gm  ~  sudo kill 18562 

Чем я выполняю apt-get update и заканчивается этим сообщением: Например: dpkg был прерван, вы должны вручную запустить sudo dpkg --configure -a чтобы исправить проблему.

И вот результат sudo dpkg --configure -a :

  ✘ erwan@gm  /etc/apt  sudo dpkg --configure -a dpkg: error processing package procps (--configure): package is in a very bad inconsistent state; you should reinstall it before attempting configuration dpkg: dependency problems prevent configuration of udev: udev depends on procps; however: Package procps is not configured yet. dpkg: error processing package udev (--configure): dependency problems - leaving unconfigured dpkg: dependency problems prevent configuration of systemd: systemd depends on udev (>= 208-8); however: Package udev is not configured yet. dpkg: error processing package systemd (--configure): dependency problems - leaving unconfigured dpkg: dependency problems prevent configuration of systemd-shim: systemd-shim depends on cgmanager (>= 0.32); however: Package cgmanager is not configured yet. dpkg: error processing package systemd-shim (--configure): dependency problems - leaving unconfigured dpkg: dependency problems prevent configuration of libpam-systemd:amd64: libpam-systemd:amd64 depends on systemd (= 215-17+deb8u4); however: Package systemd is not configured yet. libpam-systemd:amd64 depends on systemd-shim (>= 8-2) | systemd-sysv; however: Package systemd-shim is not configured yet. Package systemd-sysv is not installed. dpkg: error processing package libpam-systemd:amd64 (--configure): dependency problems - leaving unconfigured Errors were encountered while processing: procps udev systemd systemd-shim libpam-systemd:amd64 

Я также пробовал: sudo apt-get download procps

а потом :

  erwan@gm  ~  sudo dpkg --force-all -i procps_3.3.9-9_amd64.deb dpkg: warning: files list file for package 'postgresql-client-common' missing; assuming package has no files currently installed dpkg: warning: files list file for package 'postgresql-client-9.1' missing; assuming package has no files currently installed (Reading database ... 80932 files and directories currently installed.) Preparing to unpack procps_3.3.9-9_amd64.deb ... Failed to parse message: No such device or address ^Cdpkg: warning: subprocess old pre-removal script was interrupted dpkg: trying script from the new package instead ... Failed to parse message: No such device or address ^Cdpkg: error processing archive procps_3.3.9-9_amd64.deb (--install): subprocess new pre-removal script was interrupted update-rc.d: warning: start and stop actions are no longer supported; falling back to defaults Failed to parse message: No such device or address ^Cdpkg: error while cleaning up: subprocess installed post-installation script was interrupted Errors were encountered while processing: procps_3.3.9-9_amd64.deb 

но, как вы видите, это тоже не удалось.

Я понятия не имею, что делать сейчас … Пожалуйста, помогите мне!

РЕДАКТИРОВАТЬ :

@Стивен

Я попробовал ваше предложение, но он все тот же:

 erwan@gm  ~  sudo rm /etc/init.d/procps erwan@gm  ~  sudo dpkg --force-all -i procps_3.3.9-9_amd64.deb dpkg: warning: files list file for package 'postgresql-client-common' missing; assuming package has no files currently installed dpkg: warning: files list file for package 'postgresql-client-9.1' missing; assuming package has no files currently installed (Reading database ... 80932 files and directories currently installed.) Preparing to unpack procps_3.3.9-9_amd64.deb ... Unpacking procps (2:3.3.9-9) over (2:3.3.9-9) ... Setting up procps (2:3.3.9-9) ... Configuration file `/etc/init.d/procps', does not exist on system. Installing new config file as you requested. Configuration file '/etc/sysctl.conf' ==> Modified (by you or by a script) since installation. Version in package is the same as at last installation. ==> Keeping old config file as default. Failed to parse message: No such device or address ^Cdpkg: error processing package procps (--install): subprocess installed post-installation script was interrupted Processing triggers for man-db (2.7.0.2-5) ... Errors were encountered while processing: procps 

Затем я по-прежнему пытался обновить и перенаправить обновление, но по-прежнему не удалось по тем же причинам:

 Fetched 63.3 MB in 1min 28s (712 kB/s) Reading changelogs... Done Extracting templates from packages: 100% Preconfiguring packages ... Setting up procps (2:3.3.9-9) ... Failed to parse message: No such device or address 

One Solution collect form web for “Модернизация Wheezy -> Jessie Не удалось установить procps”

Сообщение « Failed to parse message вероятно, испускается кодом DBus в systemd . Попробуйте запустить или настроить dbus . Если это невозможно, попробуйте отключить LSB hook

 _SYSTEMCTL_SKIP_REDIRECT=true dpkg --configure procps 
  • словари - общий пакет жалуется на возможную коррупцию debconf
  • Обновление CentOS с 6.3 до 6.5
  • Ошибка при обновлении ubuntu (ошибки были обнаружены во время обработки)
  • Любой способ выполнить отказоустойчивое обновление без двух изображений?
  • Обновите 32-разрядную установку RHEL до 64-разрядной версии
  • apt-get dist-upgrade ничего не делает при попытке перейти с хриплого на jessie
  • `apt update` не удалось выполнить в Debian Linux
  • Демон SSH не установлен в встроенном устройстве Linux
  • Обновите / обновите Debian и пропустите любые взаимодействия
  • Различия между zypper up и zypper dup
  • Как сделать svn искать, если есть обновление раз в минуту, и если есть вызов какого-то скрипта?
  • Linux и Unix - лучшая ОС в мире.