Как установить VLC 1.1.10 или 1.1.9 в CentOS 5.6 или CentOS 6.0?

На сайте загрузки VLC нет CentOS 5.6 или 6.0 загрузок rpm. Какой RPM можно использовать для VLC 1.1.10? Если он недоступен, могу ли я просто использовать те же загрузки Fedora?

[root@www ~]# uname -a Linux www 2.6.18-194.11.4.el5 #1 SMP Tue Sep 21 05:04:09 EDT 2010 x86_64 x86_64 x86_64 GNU/Linux [root@www ~]# yum search vlc Loaded plugins: fastestmirror, replace Loading mirror speeds from cached hostfile * addons: mirror.netrino.co.uk * base: mirror.netrino.co.uk * epel: mirror01.th.ifl.net * extras: mirror.netrino.co.uk * ius: mirror.rackspace.co.uk * updates: mirror.sov.uk.goscomb.net Warning: No matches found for: vlc No Matches found [root@www ~]# 

Обновление: Это ошибка, которую я получаю:

 --> Running transaction check ---> Package vlc.x86_64 0:0.9.9a-7.el5.rf set to be updated --> Processing Dependency: libavformat.so.52(LIBAVFORMAT_52)(64bit) for package: vlc --> Processing Dependency: libavutil.so.50(LIBAVUTIL_50)(64bit) for package: vlc --> Processing Dependency: libpostproc.so.51(LIBPOSTPROC_51)(64bit) for package: vlc --> Processing Dependency: libavcodec.so.52(LIBAVCODEC_52)(64bit) for package: vlc --> Processing Dependency: libswscale.so.0(LIBSWSCALE_0)(64bit) for package: vlc --> Processing Dependency: libavcodec.so.52()(64bit) for package: vlc --> Processing Dependency: libdvdnav.so.4()(64bit) for package: vlc --> Processing Dependency: libdvbpsi.so.6()(64bit) for package: vlc --> Processing Dependency: libliveMedia.so.0()(64bit) for package: vlc --> Processing Dependency: libshout.so.3()(64bit) for package: vlc --> Processing Dependency: liblirc_client.so.0()(64bit) for package: vlc --> Processing Dependency: libkate.so.1()(64bit) for package: vlc --> Processing Dependency: libdvdread.so.3()(64bit) for package: vlc --> Processing Dependency: libavformat.so.52()(64bit) for package: vlc --> Processing Dependency: liba52.so.0()(64bit) for package: vlc --> Processing Dependency: libXvMCW.so.1()(64bit) for package: vlc --> Processing Dependency: libzvbi.so.0()(64bit) for package: vlc --> Processing Dependency: libdca.so.0()(64bit) for package: vlc --> Processing Dependency: libixml.so.2()(64bit) for package: vlc --> Processing Dependency: libcvaux.so.1()(64bit) for package: vlc --> Processing Dependency: libswscale.so.0()(64bit) for package: vlc --> Processing Dependency: libebml.so.2()(64bit) for package: vlc --> Processing Dependency: libid3tag.so.0()(64bit) for package: vlc --> Processing Dependency: libdirac_decoder.so.0()(64bit) for package: vlc --> Processing Dependency: libhighgui.so.1()(64bit) for package: vlc --> Processing Dependency: libcxcore.so.1()(64bit) for package: vlc --> Processing Dependency: libmpcdec.so.5()(64bit) for package: vlc --> Processing Dependency: libxosd.so.2()(64bit) for package: vlc --> Processing Dependency: libtwolame.so.0()(64bit) for package: vlc --> Processing Dependency: libfaad.so.2()(64bit) for package: vlc --> Processing Dependency: libpostproc.so.51()(64bit) for package: vlc --> Processing Dependency: libml.so.1()(64bit) for package: vlc --> Processing Dependency: libavutil.so.50()(64bit) for package: vlc --> Processing Dependency: libupnp.so.3()(64bit) for package: vlc --> Processing Dependency: libSDL_image-1.2.so.0()(64bit) for package: vlc --> Processing Dependency: libvgagl.so.1()(64bit) for package: vlc --> Processing Dependency: libBasicUsageEnvironment.so.0()(64bit) for package: vlc --> Processing Dependency: libmodplug.so.0()(64bit) for package: vlc --> Processing Dependency: libtag.so.1()(64bit) for package: vlc --> Processing Dependency: libQtGui.so.4()(64bit) for package: vlc --> Processing Dependency: libdirac_encoder.so.0()(64bit) for package: vlc --> Processing Dependency: libUsageEnvironment.so.0()(64bit) for package: vlc --> Processing Dependency: libportaudio.so.2()(64bit) for package: vlc --> Processing Dependency: libgroupsock.so.0()(64bit) for package: vlc --> Processing Dependency: libaa.so.1()(64bit) for package: vlc --> Processing Dependency: libcddb.so.2()(64bit) for package: vlc --> Processing Dependency: libcaca.so.0()(64bit) for package: vlc --> Processing Dependency: libmpeg2.so.0()(64bit) for package: vlc --> Processing Dependency: libcv.so.1()(64bit) for package: vlc --> Processing Dependency: libvga.so.1()(64bit) for package: vlc --> Processing Dependency: libQtCore.so.4()(64bit) for package: vlc --> Processing Dependency: libmad.so.0()(64bit) for package: vlc --> Processing Dependency: libmatroska.so.2()(64bit) for package: vlc --> Running transaction check ---> Package SDL_image.x86_64 0:1.2.10-1.el5.rf set to be updated ---> Package a52dec.x86_64 0:0.7.4-8.el5.rf set to be updated ---> Package aalib.x86_64 0:1.4.0-5.el5.rf set to be updated ---> Package dirac.x86_64 0:1.0.2-1.el5.rf set to be updated --> Processing Dependency: libcppunit-1.12.so.0()(64bit) for package: dirac ---> Package faad2.x86_64 0:2.7-1.el5.rf set to be updated ---> Package ffmpeg.x86_64 0:0.6.5-1.el5.rf set to be updated --> Processing Dependency: libx264.so.107()(64bit) for package: ffmpeg --> Processing Dependency: libmp3lame.so.0()(64bit) for package: ffmpeg --> Processing Dependency: libopencore-amrnb.so.0()(64bit) for package: ffmpeg --> Processing Dependency: libopencore-amrwb.so.0()(64bit) for package: ffmpeg --> Processing Dependency: libfaac.so.0()(64bit) for package: ffmpeg --> Processing Dependency: libgsm.so.1()(64bit) for package: ffmpeg ---> Package ffmpeg-libpostproc.x86_64 0:0.6.5-1.el5.rf set to be updated ---> Package libcaca.x86_64 0:0.99-0.1.beta17.el5.rf set to be updated --> Processing Dependency: libglut.so.3()(64bit) for package: libcaca ---> Package libcddb.x86_64 0:1.3.1-1.el5.rf set to be updated --> Processing Dependency: libcdio.so.7(CDIO_7)(64bit) for package: libcddb --> Processing Dependency: libcdio.so.7()(64bit) for package: libcddb ---> Package libdca.x86_64 0:0.0.5-1.el5.rf set to be updated ---> Package libdvbpsi.x86_64 0:0.1.7-1.el5.rf set to be updated ---> Package libdvdnav.x86_64 0:0.1.10-3.el5.rf set to be updated ---> Package libdvdread.x86_64 0:0.9.7-1.el5.rf set to be updated --> Processing Dependency: libdvdcss >= 1.2.5 for package: libdvdread ---> Package libebml.x86_64 0:1.0.0-1.el5.rf set to be updated ---> Package libid3tag.x86_64 0:0.15.1b-3.el5.rf set to be updated ---> Package libkate.x86_64 0:0.3.7-1.el5.rf set to be updated ---> Package libmad.x86_64 0:0.15.1b-4.el5.rf set to be updated ---> Package libmatroska.x86_64 0:1.0.0-1.el5.rf set to be updated ---> Package libmodplug.x86_64 0:0.8.7-1.el5.rf set to be updated ---> Package libmpcdec.x86_64 0:1.2.6-1.el5.rf set to be updated ---> Package libshout.x86_64 0:2.2.2-2.el5.rf set to be updated ---> Package libupnp.x86_64 0:1.6.6-1.el5.rf set to be updated ---> Package lirc.x86_64 0:0.6.6-4.el5.rf set to be updated ---> Package live555.x86_64 0:0-0.27.2012.02.04.el5.rf set to be updated ---> Package mpeg2dec.x86_64 0:0.4.1-2.el5.rf set to be updated ---> Package opencv.x86_64 0:1.0.0-1.el5.rf set to be updated ---> Package portaudio.x86_64 0:19-1.20071207.el5.rf set to be updated ---> Package svgalib.x86_64 0:1.9.25-1.el5.rf set to be updated ---> Package taglib.x86_64 0:1.5-1.el5.rf set to be updated ---> Package twolame.x86_64 0:0.3.13-1.el5.rf set to be updated --> Processing Dependency: libsndfile.so.1(libsndfile.so.1.0)(64bit) for package: twolame --> Processing Dependency: libsndfile.so.1()(64bit) for package: twolame ---> Package vlc.x86_64 0:0.9.9a-7.el5.rf set to be updated --> Processing Dependency: libXvMCW.so.1()(64bit) for package: vlc --> Processing Dependency: libQtGui.so.4()(64bit) for package: vlc --> Processing Dependency: libQtCore.so.4()(64bit) for package: vlc ---> Package xosd.x86_64 0:2.2.14-1.el5.rf set to be updated ---> Package zvbi.x86_64 0:0.2.33-2.el5.rf set to be updated --> Running transaction check ---> Package cppunit.x86_64 0:1.12.0-3.el5.rf set to be updated ---> Package faac.x86_64 0:1.26-1.el5.rf set to be updated ---> Package gsm.x86_64 0:1.0.13-1.el5.rf set to be updated ---> Package lame.x86_64 0:3.99.5-1.el5.rf set to be updated ---> Package libcaca.x86_64 0:0.99-0.1.beta17.el5.rf set to be updated --> Processing Dependency: libglut.so.3()(64bit) for package: libcaca ---> Package libcdio.x86_64 0:0.77-1.el5.rf set to be updated ---> Package libdvdcss.x86_64 0:1.2.10-1.el5.rf set to be updated ---> Package libsndfile.x86_64 0:1.0.17-1.el5.rf set to be updated ---> Package opencore-amr.x86_64 0:0.1.2-1.el5.rf set to be updated ---> Package vlc.x86_64 0:0.9.9a-7.el5.rf set to be updated --> Processing Dependency: libXvMCW.so.1()(64bit) for package: vlc --> Processing Dependency: libQtGui.so.4()(64bit) for package: vlc --> Processing Dependency: libQtCore.so.4()(64bit) for package: vlc ---> Package x264.x86_64 0:0.0.0-0.4.20101111.el5.rf set to be updated --> Finished Dependency Resolution vlc-0.9.9a-7.el5.rf.x86_64 from rpmforge has depsolving problems --> Missing Dependency: libQtGui.so.4()(64bit) is needed by package vlc-0.9.9a-7.el5.rf.x86_64 (rpmforge) libcaca-0.99-0.1.beta17.el5.rf.x86_64 from rpmforge has depsolving problems --> Missing Dependency: libglut.so.3()(64bit) is needed by package libcaca-0.99-0.1.beta17.el5.rf.x86_64 (rpmforge) vlc-0.9.9a-7.el5.rf.x86_64 from rpmforge has depsolving problems --> Missing Dependency: libXvMCW.so.1()(64bit) is needed by package vlc-0.9.9a-7.el5.rf.x86_64 (rpmforge) vlc-0.9.9a-7.el5.rf.x86_64 from rpmforge has depsolving problems --> Missing Dependency: libQtCore.so.4()(64bit) is needed by package vlc-0.9.9a-7.el5.rf.x86_64 (rpmforge) Error: Missing Dependency: libglut.so.3()(64bit) is needed by package libcaca-0.99-0.1.beta17.el5.rf.x86_64 (rpmforge) Error: Missing Dependency: libXvMCW.so.1()(64bit) is needed by package vlc-0.9.9a-7.el5.rf.x86_64 (rpmforge) Error: Missing Dependency: libQtCore.so.4()(64bit) is needed by package vlc-0.9.9a-7.el5.rf.x86_64 (rpmforge) Error: Missing Dependency: libQtGui.so.4()(64bit) is needed by package vlc-0.9.9a-7.el5.rf.x86_64 (rpmforge) You could try using --skip-broken to work around the problem You could try running: package-cleanup --problems package-cleanup --dupes rpm -Va --nofiles --nodigest The program package-cleanup is found in the yum-utils package. Restoring your Previous repositories...... 

2 Solutions collect form web for “Как установить VLC 1.1.10 или 1.1.9 в CentOS 5.6 или CentOS 6.0?”

Да. Вы всегда можете попробовать и посмотреть, соответствуют ли зависимости зависимым.

CentOS не нацелена на рынок настольных компьютеров, где ожидается запуск VLC. Если вы ожидаете, что это мультимедийный компьютер, возможно, вы должны использовать Fedora или другой дистрибутив, с которым хорошо работает ваше любимое программное обеспечение.

Он работает: https://www.centos.org/modules/newbb/viewtopic.php?topic_id=15725

 wget http://packages.sw.be/rpmforge-release/rpmforge-release-0.5.2-2.el5.rf.x86_64.rpm rpm --import http://apt.sw.be/RPM-GPG-KEY.dag.txt rpm -K rpmforge-release-0.5.2-2.el5.rf.*.rpm rpm -i rpmforge-release-0.5.2-2.el5.rf.*.rpm yum -y install vlc 
  • VLC в фоновом режиме и отображать его только через HDMI
  • Как отображать аудио визуализацию в VLC во время воспроизведения видео?
  • Установите VLC на Red Hat Enterprise Linux 7.2
  • CLI, чтобы начать воспроизведение вставленного DVD в VLC?
  • Почему мой единственный экземпляр VLC имеет много процессов?
  • VLC застрял в неправильной версии на Linux mint 17 (Qiana)
  • Есть ли способ инкапсулировать RTP / RTSP / RTCP в одно TCP-соединение?
  • Как играть в кодированный файл .wmv G2M4 (Ubuntu)?
  • Почему нам нужно ждать видео (через долю samba) в VLC?
  • Как возобновить видеоролики YouTube в VLC?
  • Посмотреть название песни на терминале
  • Linux и Unix - лучшая ОС в мире.