Vim: если определенная версия, то не загружайте плагин

Интересно, как лучше всего решить, нужно ли загружать какой-либо плагин в зависимости от конкретной компиляции / версии Vim. Любая помощь будет оценена по достоинству.

  • цвета vim не загружаются автоматически (вероятный конфликт Vundle)
  • Как изменить схему раскраски Gdiff в vim-fugitive plugin?
  • Экспортировать дисплей терминала в PDF
  • Что это за плагин VIM?
  • Безопасный символ в режиме ожидания
  • Как я могу открыть файл в VIM в режиме readonly, если он уже имеет swap-файл?
  • автоматическая замена vim
  • Как открыть файл в VIM и переместить курсор на результат поиска
  • One Solution collect form web for “Vim: если определенная версия, то не загружайте плагин”

    Если вы хотите, чтобы он зависел от версии, используйте это:

     if version > 700 "do stuff for version 7 and up endif 

    Если вы действительно хотите знать, работает ли определенная команда, вы можете использовать оператор exists :

     if exists('+breakindent') set breakindent endif 

    Если вы находитесь в GUI, о котором вы заботитесь, попробуйте, if has('gui_running') или поместите команды в .gvimrc .

    Linux и Unix - лучшая ОС в мире.