Ubuntu Qmake не является исполняемым файлом

после установки новой версии QtCreator в Ubuntu и

tux-world@alachiq:~ > sudo apt-get install qt5-qmake build-essential g++ gcc Reading package lists... Done Building dependency tree Reading state information... Done build-essential is already the newest version. g++ is already the newest version. g++ set to manually installed. gcc is already the newest version. qt5-qmake is already the newest version. 0 upgraded, 0 newly installed, 0 to remove and 247 not upgraded. 

в опции Build & Run и выберите qmake в /usr/bin/qmake я получаю эту ошибку:

 The qmake executable /usr/lib/i386-linux-gnu/qt4/bin/qmake could not be added: qmake '/usr/lib/i386-linux-gnu/qt4/bin/qmake' is not an executable. 

в домашней системе у меня нет проблем после установки этих пакетов и установки Qmake в опции

Дополнительная информация:

 tux-world@alachiq:~ > apt-cache search qt5-qmake qt5-qmake - Qt 5 qmake Makefile generator tool tux-world@alachiq:~ > ldd /opt/qtForArm/bin/qmake ldd: /opt/qtForArm/bin/qmake: No such file or directory tux-world@alachiq:~ > sudo chmod +x /usr/lib/i386-linux-gnu/qt4/bin/qmake [sudo] password for tux-world: chmod: cannot access '/usr/lib/i386-linux-gnu/qt4/bin/qmake': No such file or directory 

ОБНОВЛЕНИЕ :

 tux-world@alachiq:~ > apt-cache policy qt5-qmake qt5-qmake: Installed: 5.2.1+dfsg-1ubuntu14.2 Candidate: 5.2.1+dfsg-1ubuntu14.2 Version table: *** 5.2.1+dfsg-1ubuntu14.2 0 500 http://archive.ubuntu.com/ubuntu/ trusty-updates/main i386 Packages 100 /var/lib/dpkg/status 5.2.1+dfsg-1ubuntu14 0 500 http://archive.ubuntu.com/ubuntu/ trusty/main i386 Packages tux-world@alachiq:~ > ls -a -l /usr/bin/qmake lrwxrwxrwx 1 root root 9 فوریه 19 15:53 /usr/bin/qmake -> qtchooser tux-world@alachiq:~ > qtchooser Usage: qtchooser { -l | -list-versions | -print-env } qtchooser -run-tool=<tool name> [-qt=<Qt version>] [program arguments] <executable name> [-qt=<Qt version>] [program arguments] Environment variables accepted: QTCHOOSER_RUNTOOL name of the tool to be run (same as the -run-tool argument) QT_SELECT version of Qt to be run (same as the -qt argument) tux-world@alachiq:~ > 

Вы установили qt5-qmake, но ваш Qt Creator ищет Qt4 версию qmake. Вы можете установить qt4-qmake или добавить исполняемый файл Qt5 qmake в Qt Creator в Инструменты -> Параметры -> Построить и запустить -> Версии Qt.

/ edit после обновления в вопросе:

Qt Chooser – это инструмент для автоматического выбора правильных двоичных файлов Qt в зависимости от его конфигурации и / или переменных окружения.

Если вы хотите использовать Qt 5 qmake, вам нужно установить пакет qt5-default . Это укажет на различные двоичные файлы (например, /usr/bin/qmake ), предоставленные Qt Chooser, на вашу установку Qt 5. Если вы хотите использовать Qt 4 qmake, вам нужно установить qt4-default , что делает то же самое, но для Qt 4.