Ошибки Traceback, устанавливающие Python 3.6.1 на Redhat

Я боролся с этой установкой Python 3.6.1. Я пытаюсь настроить его так, чтобы любой пользователь мог запускать скрипты с 3.6.1. Обратите внимание, что Python 2.7.5 уже установлен. Любая помощь будет принята с благодарностью.

Версия Redhat:

  • Что делает программы OSX недоступными для Linux?
  • Что означает aux в `ps aux`?
  • Arch Установить wpa_supplicant из живой дуги в установленную дугу
  • Маршрутизация между несколькими подсетями
  • Почему пользователю «bin» нужна оболочка для входа?
  • Как awk уникальная строка и печать 2 строк выше
  • Linux version 3.10.0-514.el7.x86_64 (mockbuild@x86-039.build.eng.bos.redhat.com) (gcc version 4.8.5 20150623 (Red Hat 4.8.5-11) (GCC) ) #1 SMP Wed Oct 19 11:24:13 EDT 2016 

    Ошибки установки Python 3.6.1:

     Traceback (most recent call last): File "/usr/src/Python-3.6.1/Lib/runpy.py", line 193, in _run_module_as_main "__main__", mod_spec) File "/usr/src/Python-3.6.1/Lib/runpy.py", line 85, in _run_code exec(code, run_globals) File "/usr/src/Python-3.6.1/Lib/ensurepip/__main__.py", line 4, in <module> ensurepip._main() File "/usr/src/Python-3.6.1/Lib/ensurepip/__init__.py", line 189, in _main default_pip=args.default_pip, File "/usr/src/Python-3.6.1/Lib/ensurepip/__init__.py", line 102, in bootstrap _run_pip(args + [p[0] for p in _PROJECTS], additional_paths) File "/usr/src/Python-3.6.1/Lib/ensurepip/__init__.py", line 27, in _run_pip import pip zipimport.ZipImportError: can't decompress data; zlib not available make: *** [install] Error 1 

  • Где я могу найти исходный исходный код источников Linux
  • Как протестировать функцию NAPI в Linux?
  • Windows 7 для Linux: установка без CD / DVD или USB-накопителя
  • Загружать обновления с однорангового компьютера через локальную сеть
  • Получить возвращаемое значение из команды `find .. -exec ..`?
  • Обнаруживать, когда питание звуковой карты (с использованием alsa)
  • One Solution collect form web for “Ошибки Traceback, устанавливающие Python 3.6.1 на Redhat”

    Проблема заключалась в том, что zlib и zlib-devel не были установлены до установки. Мне также нужно было убедиться, что openssl и openssl-devel были установлены и обновлены, поскольку позже PIP не работал.

    Я вставил необходимые команды и зависимости ниже. Это было на Redhat 4.8.5.

      yum install gcc yum install zlib yum install zlib-devel yum install openssl yum install openssl-devel cd /usr/src wget https://www.python.org/ftp/python/3.6.1/Python-3.6.1.tgz tar xzf Python-3.6.1.tgz cd Python-3.6.1/ ./configure make make altinstall 
    Linux и Unix - лучшая ОС в мире.