Установите последнюю версию tomcat

Мне нужна версия tomcat, которая поддерживает JDK 8. Так как я использовал tomcat6, мне нужно переключиться на tomcat 7.

Проблема возникает, потому что, когда я устанавливаю ее, используя:

apt-get install tomcat7 

Версия, которую я получаю, – 7.0.26 , и, как вы можете прочитать здесь , эта версия пока не поддерживает JDK8.

Поэтому мне нужно обновить / установить в / новейшую версию tomcat 7, чтобы обеспечить ее (выпущенный, конечно).

Единственное требование моей стороны – установить его как apt-get, я имею в виду, что могу использовать его в качестве сервиса ( service tomcat7 start и все это), поэтому не хотите его устанавливать, загружая, распаковывая и запустить.

Я попытался найти другие репозитории, а затем запустил apt-get, но я не мог этого сделать (пытался добавить другой репозиторий, но не работал …)

Не могли бы вы объяснить мне, как это сделать?

заранее спасибо

PS: просто для уточнения, ожидается, что это будет запущено в Elementary OS , но настоящая целевая ОС – дистрибутив Guadalinex («испанский» (андалузский) дистрибутив, основанный на Ubuntu), так что вы могли бы сказать мне, могу ли я использовать те же шаги для этой ОС тоже? (Благодаря!)

  • Google Chrome перестает работать и не открывается
  • Как создать действие «Выключить экран»?
  • One Solution collect form web for “Установите последнюю версию tomcat”

    Это не так просто, как использование apt-get , но результат будет таким же. Если вы загружаете пакеты для Tomcat 7.0.62 из Ubuntu , они должны установить отлично в элементарной ОС и поддерживать Java 8.

    Вам нужно щелкнуть по маленькому треугольнику слева от «The Wily Werewolf» и загрузить необходимые вам файлы .deb : по крайней мере, libservlet3.0-java , libtomcat7-java , tomcat7-common и tomcat7 . Затем вы можете установить их, используя

     dpkg -i libservlet3.0-java_7.0.62-1_all.deb libtomcat7-java_7.0.62-1_all.deb tomcat7-common_7.0.62-1_all.deb tomcat7_7.0.62-1_all.deb 
    Linux и Unix - лучшая ОС в мире.