установка tmux на Ubuntu 8.04

Проводя выходные, получив унаследованную форму Ubuntu 8.04. Должен работать еще 2 года (компания внутренняя, поэтому безопасность на самом деле не проблема).

Попытка установить tmux 1.9a из источника (не в репозитории), но получить ошибку:

error: 'EVBUFFER_EOL_LF' undeclared (first use in this function) 

хотя configure работал без жалобы (после установки некоторых пакетов -dev).

Как это решить? (поэтому используется для tmux теперь, когда я не хочу возвращаться на экран). Или есть репозиторий, с которого я могу загрузить tmux.deb?

  • Как вы обновляете репозитории диспетчера пакетов YUM?
  • Запросить окно цели, если оно не отмечено
  • Выход Tmux медленнее, когда существуют вертикальные расщепления: почему?
  • Почему tmux может быть установлен только один раз на сеанс оболочки?
  • Как я могу переслать уже пересылаемый ssh-ключ в tmux?
  • Как сделать сеансы tmux count от 1 вместо 0?
  • как закончить последовательность tmux после переключения панелей
  • Истинная перезагрузка tmux config?
  • One Solution collect form web for “установка tmux на Ubuntu 8.04”

    Не могу комментировать, но проблема в том, что tmux configure не проверяет, какая библиотека libevent установлена. У Ubuntu 8.04 был libevent1 вам нужно установить libevent2 (из источника).

    Загрузите с libevent.org, последнюю стабильную версию .

     wget --no-check-certificate https://sourceforge.net/projects/levent/files/release-2.0.22-stable/libevent-2.0.22-stable.tar.gz gzip -d < libevent-2.0.22-stable.tar.gz | tar xf - cd libevent-2.0.22-stable ./configure --prefix=/usr make sudo make install ldconfig 

    и после этого настройте, скомпилируйте и установите tmux (я использовал более старую версию 2.0, но это должно решить вашу проблему).

    Linux и Unix - лучшая ОС в мире.