проблема с пакетами R на linux

Почему я должен почти всегда устанавливать библиотеки и не могу установить пакет R напрямую, как в Windows?

При установке пакета с именем Hyfo мне нужно установить библиотеки трех разных зависимостей вручную. Мне нужно много времени искать имя библиотек для установки, чтобы я мог правильно установить Hyfo.

Например, для пакета rgdal:

sudo apt-get install libgdal-dev libproj-dev 

Как я могу узнать, что устанавливать каждый раз, когда пакет «имеет ненулевой статус»?

У меня есть Lubuntu Peppermint OS 7.

Linux – это не окна. Существует принципиальное различие между ними.

В Linux предполагается, что правильная установка приложений должна следовать примеру этого документа. http://www.pathname.com/fhs/pub/fhs-2.3.html

Предполагается, что он будет предоставлять доступ к библиотекам и «коду», чтобы, например, ваш музыкальный проигрыватель и проигрыватель фильмов могли использовать одну и ту же библиотеку «make sounds».

Windows «может» сделать это тоже, но часто этого не делает. Более часто исполняемые файлы в окнах упаковываются со своими зависимостями. В Linux только исполняемый файл упакован. Библиотеки отмечены как зависимости. Такие системы, как apt, могут автоматически разрешать эти зависимости. Ваш пакет «R», вероятно, просто плохо определен или не установлен через apt.

Поэтому либо используйте apt для установки пакетов, либо используйте установщик пакетов для поиска и установки зависимостей.

Рубинский спутник хорошо справляется с этим. R, по-видимому, дает вам проблемы.

Вы не можете установить пакет через один менеджер пакетов и ожидать, что другой узнает о его зависимостях.