Конфликт Python psutil для Терминатора на Centos 7

Эта проблема началась после установки последних обновлений, вероятно, за последние 2-3 дня. Когда я пытаюсь открыть Terminator, я получаю ошибку,

Traceback (most recent call last): File "/usr/bin/terminator", line 23, in <module> import psutil File "/usr/lib64/python2.7/site-packages/psutil/__init__.py", line 181, in <module> raise ImportError(msg) ImportError: version conflict: '/usr/lib64/python2.7/site-packages/psutil/_psutil_linux.so' C extension module was built for another version of psutil (different than 2.2.1) 

Я использую Centos 7.2 (64 бит). За последний месяц я не установил ни одного другого программного обеспечения или каких-либо других библиотек python.

One Solution collect form web for “Конфликт Python psutil для Терминатора на Centos 7”

Я столкнулся с той же проблемой и работал вокруг нее, установив версию psutil указанную в ошибке.

sudo pip install psutil==2.2.1

  • Преобразование файла субтитров xml в формат srt
  • Источники Python компилируют другую версию
  • Как создать выход в скрипт python, запущенный при загрузке?
  • Как выполнить программу в Xfce и использовать другую тему xfwm4, отличную от стандартной?
  • Как добавить к переменной среды с помощью файла .env?
  • Разрешения python && unix (gitlab)
  • Использовать вкладки для отступов в режиме Python
  • Как автоматически создать папку времени выполнения с помощью службы systemd или tmpfiles.d?
  • OPENSSL_1.0.0 не найден при запуске PyPy 4.0.1 на Amazon Linux (AWS EC2)
  • Как отключить кеши L1 и L2 процессора?
  • обновить Python до 2.7.2
  • Поймать / диагностировать процесс уничтожения пользователя - Необязательно выходить из системы автоматически
  • Linux и Unix - лучшая ОС в мире.