Запустите pulseaudio в качестве демона в Linux Mint 18.1

Linux Mint 18.1 поставляется с pulseaudio версии 8.0 в качестве звуковой системы. В linuxmint 17.3 У меня есть версия 4.0 и файл /etc/init/pulseaudio.conf где pulseadio настроен для начала работы с линией

 start on runlevel [2345] 

Копирование файла в /etc/init не помогло. Мне нужно это из-за конфигурации multiseat.

  • Не удалось подключить debian к android через bluetooth
  • Изменение источника входного аудио и установка его в моно на Debian Jessie / 8 с использованием команд
  • как использовать Bluetooth-устройство с профилем HSP / HFP с использованием pulseaudio> = 6 и bluez> = 5.24
  • Как узнать, используется ли мой микрофон или нет?
  • Сервер PulseAudio на Android
  • Автоматическое переключение профилей PulseAudio на основе количества входных (ых) каналов
  • Pulseaudio, Phonon, KDE и пересылка звука на гарнитуру
  • gentoo alsa pulseaudio - alsa mixer работает; aplay прямо к hw: 1,0 работ; aplay для любого из настроенных PCM не работает
  • One Solution collect form web for “Запустите pulseaudio в качестве демона в Linux Mint 18.1”

    Проблема была в system.pa. Я нашел в руководстве, что в системном демонах конфигурации не следует использовать автоматическое обнаружение.

    с пульсирующих страниц руководства:

      --disallow-module-loading[=BOOL] Disallow module loading after startup. This is a security feature since it disallows additional module loading during runtime and on user request. It is highly recommended when --system is used (see above). Note however, that this breaks certain fea‐ tures like automatic module loading on hot plug. 

    Поэтому я отключил (прокомментировал) строки из system.pa

      ### Automatically load driver modules depending on the hardware available #.ifexists module-udev-detect.so #load-module module-udev-detect #.else #### Use the static hardware detection module (for systems that lack udev/hal support) #load-module module-detect #.endif 

    и теперь работает.

    Linux и Unix - лучшая ОС в мире.