Установите postgresql 9.2 на debian wheezy (на виртуальном боксе)

У меня есть виртуальный бокс с Debian Wheezy. Я пытаюсь установить Postgresql 9.2 на него. Когда я пытаюсь сделать это с помощью этой инструкции, у меня есть следующее:

Reading package lists... Done Building dependency tree Reading state information... Done Some packages could not be installed. This may mean that you have requested an impossible situation or if you are using the unstable distribution that some required packages have not yet been created or been moved out of Incoming. The following information may help to resolve the situation: The following packages have unmet dependencies: postgresql-9.2 : Depends: postgresql-common (>= 135~) but it is not going to be installed Depends: ssl-cert but it is not installable E: Unable to correct problems, you have held broken packages. 

Когда я пытаюсь установить postgresql-common:

 apt-get install postgresql-common 

Я получил следующее:

 Reading package lists... Done Building dependency tree Reading state information... Done Some packages could not be installed. This may mean that you have requested an impossible situation or if you are using the unstable distribution that some required packages have not yet been created or been moved out of Incoming. The following information may help to resolve the situation: The following packages have unmet dependencies: postgresql-common : Depends: ssl-cert (>= 1.0.11) but it is not installable E: Unable to correct problems, you have held broken packages 

Когда я пытаюсь установить ssl-cert:

 apt-get install ssl-cert 

Я получил следующее:

 Reading package lists... Done Building dependency tree Reading state information... Done Package ssl-cert is not available, but is referred to by another package. This may mean that the package is missing, has been obsoleted, or is only available from another source E: Package 'ssl-cert' has no installation candidate 

Я новичок в Linux, пожалуйста, помогите мне установить Postgresql 9.2

Есть мои sources.list

 # # deb cdrom:[Debian GNU/Linux 7.0.0 _Wheezy_ - Official i386 CD Binary-1 201305$ deb cdrom:[Debian GNU/Linux 7.0.0 _Wheezy_ - Official i386 CD Binary-1 20130504$ deb http://security.debian.org/ wheezy/updates main deb-src http://security.debian.org/ wheezy/updates main # wheezy-updates, previously known as 'volatile' # A network mirror was not selected during install. The following entries # are provided as examples, but you should amend them as appropriate # for your mirror of choice. # # deb http://ftp.debian.org/debian/ wheezy-updates main # deb-src http://ftp.debian.org/debian/ wheezy-updates main 

Добавьте это в свой sources.list :

 deb http://ftp.de.debian.org/debian/ wheezy main non-free contrib deb-src http://ftp.de.debian.org/debian/ wheezy main non-free contrib 

Убедитесь, что вы используете соответствующее зеркало для своего местоположения.

Запустите aptitude update или apt-get update и завершите установку.

Интерактивный способ aptitude весьма полезен для решения зависимостей.