Установка php5-mcrypt для phpmyadmin

Я пытаюсь установить phpmyadmin на сервере. К сожалению, я получаю следующую ошибку:

Reading package lists... Done Building dependency tree Reading state information... Done Some packages could not be installed. This may mean that you have requested an impossible situation or if you are using the unstable distribution that some required packages have not yet been created or been moved out of Incoming. The following information may help to resolve the situation: The following packages have unmet dependencies: phpmyadmin : Depends: php5-mcrypt but it is not going to be installed E: Unable to correct problems, you have held broken packages. 

И вот вывод, когда я пытаюсь установить php5-mcrypt:

 Reading package lists... Done Building dependency tree Reading state information... Done Some packages could not be installed. This may mean that you have requested an impossible situation or if you are using the unstable distribution that some required packages have not yet been created or been moved out of Incoming. The following information may help to resolve the situation: The following packages have unmet dependencies: php5-mcrypt : Depends: phpapi-20100525 Depends: php5-common (= 5.4.17-5+debphp.org~precise+1) but 5.5.0-1ubuntu2~raring2~precise1 is to be installed E: Unable to correct problems, you have held broken packages. 

Я попытался (предварительно) следовать указаниям на этом сайте, но я действительно ничего не могу сломать на этом сервере. Мой вопрос имеет несколько частей:

Во-первых, что именно означает значение Depends: information? Когда он говорит = 5.4.17 т. Д., Мне нужна именно эта версия?

Во-вторых, как я могу гарантировать, что если я что-то испортил, я могу «откат» в предыдущее состояние? Насколько это возможно? На всякий случай у меня есть пакеты php5 и apache2 , но я думаю, что я также должен сохранить файлы конфигурации. Это так? Есть ли определенные файлы конфигурации, которые я должен создать резервную копию?

Наконец, как я могу исправить эту проблему? Какие (безопасные) шаги следует предпринять, чтобы установить phpmyadmin?

ОБНОВЛЕНИЕ:

Я должен отметить, что у меня есть только доступная мне командная строка.

Результатом политики apt-cache policy php5-common является:

 php5-common: Installed: 5.5.0-1ubuntu2~raring2~precise1 Candidate: 5.5.0-1ubuntu2~raring2~precise1 Version table: *** 5.5.0-1ubuntu2~raring2~precise1 0 500 http://ppa.launchpad.net/zanfur/php5.5/ubuntu/ precise/main amd64 Packages 100 /var/lib/dpkg/status 5.4.17-5+debphp.org~precise+1 0 500 http://ppa.launchpad.net/ondrej/php5-oldstable/ubuntu/ precise/main amd64 Packages 5.3.10-1ubuntu3.7 0 500 http://us.archive.ubuntu.com/ubuntu/ precise-updates/main amd64 Packages 500 http://security.ubuntu.com/ubuntu/ precise-security/main amd64 Packages 5.3.10-1ubuntu3 0 500 http://us.archive.ubuntu.com/ubuntu/ precise/main amd64 Packages 

  • nme для установки целевой Linux не работает на debian
  • Как я могу убить процесс, выполняющийся на определенном IP-адресе и порту?
  • Некоторые информационные страницы отсутствуют
  • Обновление единого пакета от Ubuntu Utopic Unicorn при запуске Trusty Tahr
  • tun0 после установки openvpn
  • Списки команд ls скрывают файлы
  • Как вы исправляете обновление apt-get «Несоответствие хэш-суммы»
  • Как я могу просмотреть мою гостевую файловую систему virtualix guest в файле / текстовом редакторе Windows?
  • One Solution collect form web for “Установка php5-mcrypt для phpmyadmin”

    Проблема в том, что вы включили два отдельных PPA для PHP. Вы установили PHP5 с использованием PPA из «zanfur», но его php-mcrypt имеет более старую версию, чем версия «ondrej».

    Если вы удалите PPA для ondrej, вы должны получить версию из репо, из которой вы установили PHP (хотя, похоже, она также не является правильной версией).

    Linux и Unix - лучшая ОС в мире.