Не удается установить php-mssql или freetds на Centos7

Моя цель – подключиться к MS SQL Server 2005 с помощью PHP. Я установил PHP и ODBC. Я запускаю CentOS7.

PHP Version => 5.4.16 

…. (от php -i) ….

 odbc ODBC Support => enabled 

При попытке установить freetds и расширение php-mssql я столкнулся с 2 проблемами зависимости. (Смотри ниже)

 [root@localhost freetds-dev.0.92.377]# yum install php-mssql freetds Loaded plugins: fastestmirror, langpacks Loading mirror speeds from cached hostfile * base: mirror.supremebytes.com * epel: mirror.sfo12.us.leaseweb.net * extras: mirrors.cat.pdx.edu * rpmforge: mirror.hmc.edu * updates: ftp.osuosl.org Resolving Dependencies --> Running transaction check ---> Package freetds.x86_64 0:0.91-2.el6 will be installed --> Processing Dependency: libgnutls.so.26(GNUTLS_1_4)(64bit) for package: freetds-0.91-2.el6.x86_64 --> Processing Dependency: libgnutls.so.26()(64bit) for package: freetds-0.91-2.el6.x86_64 ---> Package php-mssql.x86_64 0:5.3.3-3.el6 will be installed --> Processing Dependency: php(zend-abi) = 20090626 for package: php-mssql-5.3.3-3.el6.x86_64 --> Processing Dependency: php(api) = 20090626 for package: php-mssql-5.3.3-3.el6.x86_64 --> Finished Dependency Resolution Error: Package: freetds-0.91-2.el6.x86_64 (epel) Requires: libgnutls.so.26()(64bit) Error: Package: php-mssql-5.3.3-3.el6.x86_64 (epel) Requires: php(api) = 20090626 Installed: php-common-5.4.16-23.el7_0.3.x86_64 (@updates) php(api) = 20100412-64 Available: php-common-5.4.16-21.el7.x86_64 (base) php(api) = 20100412-64 Available: php-common-5.4.16-23.el7_0.x86_64 (updates) php(api) = 20100412-64 Available: php-common-5.4.16-23.el7_0.1.x86_64 (updates) php(api) = 20100412-64 Error: Package: freetds-0.91-2.el6.x86_64 (epel) Requires: libgnutls.so.26(GNUTLS_1_4)(64bit) Error: Package: php-mssql-5.3.3-3.el6.x86_64 (epel) Requires: php(zend-abi) = 20090626 Installed: php-common-5.4.16-23.el7_0.3.x86_64 (@updates) php(zend-abi) = 20100525-64 Available: php-common-5.4.16-21.el7.x86_64 (base) php(zend-abi) = 20100525-64 Available: php-common-5.4.16-23.el7_0.x86_64 (updates) php(zend-abi) = 20100525-64 Available: php-common-5.4.16-23.el7_0.1.x86_64 (updates) php(zend-abi) = 20100525-64 You could try using --skip-broken to work around the problem You could try running: rpm -Va --nofiles --nodigest 

У меня есть libgnutls.so версии 28, хотя

 /usr/lib64/libgnutls.so.28 /usr/lib64/libgnutls.so.28.20.4 

Пакет, который вы пытаетесь установить, имеет el6 в версии, указывающую, что это для CentOS 6, а не 7. Похоже, вы добавили репозиторий EPEL для неправильной версии CentOS. Вы должны удалить конфигурацию yum для EPEL6 и добавить конфигурацию для 7. Вы можете добавить конфигурацию для 7 со следующим:

 rpm -Uvh http://mirror.oss.ou.edu/epel/7/x86_64/e/epel-release-7-5.noarch.rpm 

Я борюсь с той же проблемой, и я знаю, что я на OS 7.

Должен ли я попытаться установить freetds отдельно?

 Red Hat Enterprise Linux Server release 7.3 (Maipo) Installed: epel-release.noarch 0:7-9 Error: Package: freetds-0.91-2.el6.x86_64 (epel) Requires: libgnutls.so.26(GNUTLS_1_4)(64bit) /usr/lib64/.libgnutls.so.28.41.16.hmac /usr/lib64/.libgnutls.so.28.hmac /usr/lib64/libgnutls.so.28 /usr/lib64/libgnutls.so.28.41.16