Как обновить PHP до 5.3 на Debian 5.0 (Lenny)?

В настоящее время у меня установлен PHP 5.0 на моем Debian VPS, и мне было интересно, как я смогу обновить его до PHP 5.3 и сохранить все установленные мои модули.

  • Сценарий для удаления файлов, не соответствующих определенным именам файлов
  • установить php7 вместе с php5 на Ubuntu
  • Cron сообщает об ошибке в php5-общем задании после обновления
  • Не удается запустить php cli в webuser, но будет выполняться как root
  • Arch Linux: я получаю 500 ошибок при попытке открыть файл PHP
  • Ошибка Apache2 uncached Exception 500
  • Как POST «вывод оболочки» как данные JSON с помощью Curl
  • Получение PHP для работы с apache для запуска файлов .php через браузер
  • 4 Solutions collect form web for “Как обновить PHP до 5.3 на Debian 5.0 (Lenny)?”

    Если вы еще не проверили, вы должны проверить, находится ли пакет, который вы хотите, в backports перед добавлением тестирования или неустойчивым к вашим источникам. Если это не так, вам нужно быть очень осторожным в том, чтобы вытаскивать пакеты из других выпусков, они также могут обновить многие другие вещи в системе.

    Вы можете взглянуть на dotdeb . Они имеют пакеты Debian для серверов LAMP на базе Debian и предлагают, среди прочего, пакеты для PHP 5.3.

    нестабильные репозитории содержат прямо сейчас версию php 5.3.3-2.

    Используя тестовую среду, добавьте неустойчивый в список источников и просто попробуйте:

    apt-get update apt-get install php5 

    В моем предыдущем опыте он работает очень хорошо. Если вы используете нестандартные модули, проверьте их совместимость перед попыткой обновления.

    В промежуточной области для следующего выпуска Debian, Squeeze, с начала 2010 года был PHP 5.3. Итак, добавьте squeeze в свой ' /etc/apt/sources.list ', а затем:

     apt-get update apt-get --simulate install php5 

    Проверьте вывод, убедитесь, что важные пакеты не будут удалены, а системные библиотеки не будут обновлены (или сохраните их на минимальном уровне), и если все будет выглядеть нормально:

     apt-get install php5 

    Конечно, это должна быть временная мера. То есть, удалите эту строку сжатия из « source.list », когда вы закончите установку этого PHP.

    Interesting Posts

    Debian, nonroot, cron, bash и перезагрузка в определенное время

    Как временно отключить устройство мыши?

    Почему Debian Wheezy не отображает значки на рабочем столе?

    Неверный inode: поврежден f2fs, fsck.f2fs не может восстановить

    Установка Arch Linux с загрузкой UEFI и макета GPT

    Извлечь определенный текст из переменной в сценарии оболочки

    Как сделать доступную беспроводную точку доступа (локальный сервер) без подключения к Интернету?

    PULSEAUDIO не отображает мое устройство захвата ALSA в качестве источника захвата

    Статический IP-адрес без шлюза

    Linux RAID с использованием материнской платы Intel

    Невозможно выйти из меню KDE OpenSuSE

    Предоставить парольную фразу для запроса plymouth ask-for-password из командной строки

    Команда Logger – как хранить журналы в заданном файле?

    Передача аргументов для напоминаний о событиях на KOrganizer bash / yad

    Не удается загрузить новую Linux с USB-устройства

    Linux и Unix - лучшая ОС в мире.