Pacman Полная система обновления требует замены пакетов

Каждый раз, когда я делаю полное обновление системы, pacman задает мне тот же вопрос:

tarting full system upgrade... :: Replace mga-dri with extra/libgl? [Y/n] n :: Replace r128-dri with extra/libgl? [Y/n] n :: Replace sis-dri with extra/libgl? [Y/n] n :: Replace tdfx-dri with extra/libgl? [Y/n] n 

и каждый раз я нажимаю no.

Это что-то раздражает.

Как я могу это исправить?

Вы должны занести в черный список соответствующие пакеты. Измените файл /etc/pacman.conf :

 IgnorePkg = mga-dri r128-dri sis-dri tdfx-dri 

Таким образом, pacman не будет пытаться обновлять эти пакеты до тех пор, пока они занесены в черный список.