Ошибка командной строки в OpenSUSE (старая версия)

Я использую старую версию OpenSUSE и когда я пытаюсь обновить некоторый пакет через командную строку, например

Zypper update firefox 

он показывает сообщение, указанное ниже.

Управление системой заблокировано приложением с помощью pid 2181 (/ usr / sbin / packagekitd).
Закройте это приложение, прежде чем повторять попытку.

One Solution collect form web for “Ошибка командной строки в OpenSUSE (старая версия)”

У вас уже запущен экземпляр Zypper , об этом сообщает сообщение об ошибке. Просто убейте другой процесс и повторите попытку:

 sudo kill 2181 

Если это не работает, попробуйте

 sudo kill -9 2181 
  • Добавление монохранилища openSuSe?
  • yast2 разбился в момент загрузки программного модуля установки
  • Почему этот RPM «uninstallable»?
  • Проблема: ничего не предоставляет libcrypto.so.10 () (64 бит), необходимый Percona-Server-client-57-5.7.10-3.1.el7.x86_64
  • zypper устанавливает специальную основную версию без указания малой версии
  • Различия между zypper up и zypper dup
  • OpenSUSE: найти все пакеты без репозитория
  • Как установить шаблоны и пакеты одновременно?
  • Как И-слова в поиске zypper?
  • Что такое эквивалент Opensuse `apt-get source`?
  • Как установить subversion 1.6.x на SLE11?
  • Linux и Unix - лучшая ОС в мире.