Обновление openssl от 0.9.8j-0.50.1 до 1.0.2a на SLES11SP3

Мне нужно обновить OPENSSL от 0.9.8j-0.50.1 -> 1.0.2a на сервере, который запускает sles11 sp3 для динамической привязки к моей программе.

Шаги для обновления моей среды сборки (sles11sp3):

1. Загрузите пакет с https://www.openssl.org/source/ и следуйте ниже,

a) wget https://www.openssl.org/source/openssl-1.0.2a.tar.gz b) ./ config -fPIC shared –prefix = / usr –openssldir = / etc / ssl c) make d ) make install INSTALL_PREFIX = / home / Release / openssl / e) cd / home / Release / openssl / d) ls -lf) cp -rf * /

2. Теперь, если выполняется версия openssl, ее показы отображаются ниже (Ожидается),

OpenSSL> version OpenSSL 1.0.2a 19 Mar 2015 OpenSSL> 

3. После этого, компилируя мою программу (которая имеет SNMP, CURL), я вижу два предупреждения о компиляции ниже,

/usr/lib64/gcc/x86_64-suse-linux/4.3/../../../../x86_64-suse-linux/bin/ld: предупреждение: libcrypto.so.0.9.8, необходимое для / usr / lib64 / libnetsnmpagent.so, может конфликтовать с libcrypto.so.1.0.0

  /usr/lib64/gcc/x86_64-suse-linux/4.3/../../../../x86_64-suse-linux/bin/ld: warning: libssl.so.0.9.8, needed by /usr/lib64/libcurl.so, may conflict with libssl.so.1.0.0 

4. Исправляя это предупреждение, создайте следующую символическую ссылку в каталоге / usr / lib64, как показано ниже,

cd / usr / lib64 ln -sf libssl.so.1.0.0 libssl.so.0.9.8 ln -sf libcrypto.so.1.0.0 libcrypto.so.0.9.8

5. Теперь я не вижу предупреждения о компиляции, а также генерируется rpm (myprogram.rpm).

6. Те же шаги (кроме 3), которые следуют на моем корпоративном сервере (при этом мне нужно запустить мою программу), которая работает на том же sles11 sp3.

 rpm -ivh myprogram.rpm error:Failed dependencies: libcrypto.so.1.0.0()(64bit) is needed by myprogram libssl.so.1.0.0()(64bit) is needed by myprogram 

Пожалуйста, предложите мне, где я делаю неправильно или что-то не хватает.

Linux и Unix - лучшая ОС в мире.