Articles of qtcreator

Отличается ли переменная среды $ PATH среды рабочего стола от среды оболочки?

Я пытаюсь найти файл .desktop для qtcreator, поэтому я пишу это: $ for p in ${XDG_DATA_DIRS//:/ }; do grep -rni ‘qtcreator’ $p; done И вот самые актуальные строки: /usr/share/app-install/desktop/qtcreator-plugin-ubuntu:ubuntusdk.desktop:2:X-AppInstall-Package=qtcreator-plugin-ubuntu /usr/share/app-install/desktop/qtcreator-plugin-ubuntu:ubuntusdk.desktop:6:Exec=qtcreator %F /usr/share/app-install/desktop/qtcreator-plugin-ubuntu:ubuntusdk.desktop:7:Icon=ubuntu-qtcreator /usr/share/app-install/desktop/qtcreator:qtcreator.desktop:2:X-AppInstall-Package=qtcreator /usr/share/app-install/desktop/qtcreator:qtcreator.desktop:6:Exec=qtcreator %F /usr/share/app-install/desktop/qtcreator:qtcreator.desktop:7:Icon=QtProject-qtcreator /usr/share/app-install/desktop/qhimdtransfer:qhimdtransfer.desktop:12:#Icon=qtcreator_logo_32 Я думаю, что qtcreator:qtcreator.desktop – это запись рабочего стола для QtCreator, поэтому я открываю ее и выясняю: [Desktop […]

Qt Creator не запускается в OpenSUSE

Спустя несколько лет, используя Ubuntu, я решил вернуться к OpenSUSE. Я установил Qt Creator с помощью онлайн-установщика из Qt вместе со всеми версиями фреймворков, которые я хотел. Qt Creator отказывается запускаться. При запуске из командной строки появляется следующая ошибка: static QPlatformTheme* QKdeTheme::createKdeTheme(): Unable to determine KDE dirs Мне удалось установить Qt 5 Creator из репозиториев […]

Ubuntu Qmake не является исполняемым файлом

после установки новой версии QtCreator в Ubuntu и tux-world@alachiq:~ > sudo apt-get install qt5-qmake build-essential g++ gcc Reading package lists… Done Building dependency tree Reading state information… Done build-essential is already the newest version. g++ is already the newest version. g++ set to manually installed. gcc is already the newest version. qt5-qmake is already the […]

Как заставить Qt Creator использовать цветовую схему KDEs

У меня есть более темная цветовая схема, чем у моей цветовой схемы KDE, но текстовая область в Qt Creator по-прежнему белая. Как заставить Qt Creator использовать цветовую схему KDE (например, Kate)?

Не удается запустить qtcreator

Я пытаюсь запустить qtcreator , но вот что я получаю: $ qtcreator libGL error: No matching fbConfigs or visuals found libGL error: failed to load driver: i965 libGL error: No matching fbConfigs or visuals found libGL error: failed to load driver: swrast QQuickWidget: Failed to make context current QQuickWidget::resizeEvent() no OpenGL context Manjaro Linux x64, […]

Как запретить приложения Qt использовать тему GTK +

Всякий раз, когда я хочу использовать пользовательские компоненты QML в своих приложениях, это заставляет их использовать тему GTK +. Как я могу это предотвратить? Почему я спрашиваю здесь? Потому что я считаю, что это имеет какое-то отношение к файлам типа: ~/.config/qt.conf или что-то еще. И я должен сделать что-то вроде: [Qt] GTK-theme: false Или что-то […]

Установка Qt Creator на Debian

Я следую этому руководству http://exploringbeaglebone.com/chapter11/, и я застрял на части Перейдите на вкладку «Qt Versions» и нажмите «Добавить …» и перейдите в / usr / bin /, где вы увидите записи qmake и qmake-qt4. Нажмите qmake, а затем нажмите «Открыть». Затем вы должны увидеть, что версия Qt для ручного управления появилась, как показано на рисунке […]

Поиск зависимостей для скомпилированной программы на C ++

Я написал и скомпилировал программу на C ++ с помощью Qt Creator в Ubuntu 13.10 (32 бит). Я попытался запустить скомпилированную программу в недавно установленном Ubuntu 13.10 (64 бит). Но это не работает. Я думаю, что проблема связана с зависимостями. Как я могу найти (= знать имя и версию) необходимые зависимости?

Как изменить, какая версия Qt используется для qmake?

Я чувствую, что должен быть простой способ сделать это, но мой googlefu терпит неудачу, поэтому я действительно ценю некоторую информацию о том, как переключаться (или даже постоянно меняться), какая версия Qt используется при выполнении qmake. Если я спрошу, в какой версии я получаю следующее: ~ $ qmake –version QMake version 3.0 Using Qt version 5.0.1 […]