Tag: package management

Можно ли удалить vi?

Я хочу удалить текстовый редактор vi из Linux, но он не отображается как пакет в aptitude. Можно ли это удалить? Я уже удалил vim, запустив sudo apt-get remove vim Я использую Linux Mint.

Как установить / обновить только определенный пакет в Fedora из репо?

Недавно я добавил неофициальную стороннюю репо для установки Fedora 23. В основном меня интересует пакет simplescreenrecorder , который предоставляет это репо, поскольку он недоступен в официальных репозиториях Fedora или RPMFusion. Я хотел бы установить стороннее репо таким образом, чтобы только этот пакет simplescreenrecorder устанавливался / обновлялся с их зависимостями и ничего больше. Я попытался добавить […]

Как автоматически устанавливать пакеты?

Я хочу установить пакеты автоматически, запустив скрипт Я могу написать yum install php , но я хочу, чтобы он установил другой пакет после завершения установки пакета php. Есть ли какое-либо решение, чтобы сделать его автоматическим? У меня около 20 пакетов, которые должны быть загружены из ремиксов.

`apt clean` vs` apt-get clean`

Являются ли эти apt команды идентичными их apt-get аналогам / именам? apt clean apt-get clean apt autoclean apt-get autoclean apt autoremove apt-get autoremove Они кажутся. Просто хочу подтвердить.

Ошибка при установке wireless-bcm43142-dkms-6.20.55.19: зависимые linux-заголовки не выполняются

Я должен установить файл .deb с прошивкой для Wi-Fi-карты (это имя файла: wireless-bcm43142-dkms-6.20.55.19_amd64.deb; я загрузил файл здесь: http: // www.filewatcher.com/m/wireless-bcm43142-dkms_6.20.55.19-1_amd64.deb.1337086-0.html ). Когда я пытаюсь установить файл .deb, я дважды щелкаю по файлу, но он дает мне эту ошибку: "Failed to install file. Unknown error. Please refer to detailed report and report in your distribution bug […]

Пакет, установленный как зависимость, не удаляется с помощью «apt-get autoremove»

Я использую LXDE, и когда я установил gnome-screensaver , у него было множество зависимостей, включая pulseaudio . Затем я сразу же удалил его с помощью autoremove (без промежуточных шагов), но ничего из зависимостей не было удалено. Почему это? Это мое из /var/log/apt/history.log : Start-Date: 2014-07-05 18:49:28 Commandline: apt-get install gnome-screensaver Install: gnome-sushi:amd64 (0.4.1-3, automatic), python-packagekit:amd64 […]

Как я могу исправить свой менеджер пакетов?

Im работает Debian 7.0 (3.16.0-0.bpo.4-amd64) около года, и он работает нормально. Вчера я сделал apt-get dist-upgrade и после некоторого ухаживания с Nginx он снова работал отлично. Однако всякий раз, когда я пытаюсь использовать диспетчер пакетов для некоторого общего пакета (который можно найти на сайте debian), я не могу загрузить его через диспетчер пакетов. Мои источники.list: […]

Fedora12, yum не могут найти репозитории

По некоторым причинам мне приходится использовать старый дистрибутив Fedora12, а yum в своей конфигурации по умолчанию не может найти URL-адреса для пакетов. % yum search gcc Loaded plugins: refresh-packagekit Error: Cannot retrieve repository metadata (repomd.xml) for repository: fedora/ Please verify its path and try again Конфигурация репозитория YUM на /etc/yum.repos.d/fedora.repo имеет следующее: #baseurl=http://download.fedoraproject.org/pub/fedora/linux/releases/$releasever/Everything/$basearch/os/ mirrorlist=https://mirrors.fedoraproject.org/metalink?repo=fedora-$releasever&arch=$basearch Это […]

Добавить репозитории в Kali Linux 2.0

Как добавить репозитории в Kali Linux 2.0, и что, если таковые имеются, являются последствием этого?

Установка пользовательских пакетов в Linux

В настоящее время я использую Kali, иногда чистый Debian, и иногда я хочу установить пакет, который не входит в список моих источников. И вы не можете найти их и добавить в исходный файл. Я имею в виду, что я загружаю новый Python, который равен 3.5.2 , а на моей ОС есть Python 3.4.3 . Поэтому […]

Linux и Unix - лучшая ОС в мире.