Articles of firefox

Ubuntu VM под прокси: браузер не может разрешить DNS

Я не совсем понимаю, почему я не могу получить разрешение dns lookpu в моем браузере (firefox) на моей виртуальной машине с Ubuntu. apt-get , git , maven , gradle и другие инструменты настроены для использования параметров прокси-сервера и могут напрямую разрешать и загружать пакеты и зависимости. Я так устал, чтобы попытаться выяснить, что не так. […]

Меню Firefox «3 бара» не открывается

Я использую Linux Mint KDE и в последнее время у меня возникают проблемы с Firefox. Когда я пытаюсь открыть меню Firefox (меню справа с 3 барами), щелчок не действует. Нажатие alt открывает более традиционные файловые меню, так что я могу получить доступ ко всему так. Однако я бы предпочел, чтобы Firefox работал так, как задумано. […]

Как исправить ошибку Fontconfig: не удалось прочитать файл конфигурации

При тестировании Debian каждый раз, когда я запускаю браузер из терминала, я получаю четыре строки следующей ошибки: Fontconfig error: failed reading config file Похоже, что это не вызывает никаких проблем ни в одном приложении, только в Firefox Quantum, установленном с помощью рендеринга шрифтов с snap , работает неправильно, как здесь и здесь . Я уже […]

Firefox пишет все слова с версии 61

В моем Debian 9 с Firefox 61 каждое слово помечено как написанное с ошибками, кроме цифр (сейчас, в данный момент, когда я печатаю). Вещи, которые я пробовал: Удалите en-US словарь и верните его (пришлось жестко удалять файлы, так как при простом удалении расширения не удалялись файлы или опция меню). Добавьте второй словарь – он добавил […]

Firefox завис на версии 58 после запуска apt install

Когда я бегу apt update apt get install firefox затем apt-cache policy firefox производит Installed: 61.0.1+linuxmint1+rosa Однако, если я запускаю его с помощью Firefox в терминале или в меню «Пуск» и иду в «Справка-> О Firefox», он по-прежнему показывает версию 58. Как мне убедиться, что у меня 61?

Скрипт `/ etc / network / if-up.d` запускается, но не запускает приложения с графическим интерфейсом (например, firefox-esr)

Мне нужно запустить firefox-esr только сеть станет доступной. Вот что у меня есть: sudo tee “/etc/network/if-up.d/upif” > /dev/null <> /var/log/upif firefox-esr & fi EOFBOOT sudo chmod +x “/etc/network/if-up.d/upif” Я получаю дату и имя интерфейса в моем файле журнала, что означает, что скрипт выполняется, но firefox-esr не запускается. Что я пробовал: добавление DISPLAY=”:0″ grep -inR “firefox” […]

Ошибка зависимостей в Debian 9 Stretch

Я пытаюсь установить Firefox Quantum, следуя советам пользователя @cas в этом вопросе . Все идет хорошо, пока я не попытаюсь установить Firefox, запустив в терминале: $ apt install -t sid firefox Здесь я получаю следующее сообщение об ошибке: Следующие пакеты имеют неудовлетворенные зависимости: firefox: Зависит от: libc6 (> = 2.27), но 2.24-11 + deb9u3 должен […]

веб-браузеры увеличивают по умолчанию в Ubuntu 14.04.5 LTS

Я испытываю странное поведение, когда Chromium (версия 61.0) и Firefox (версия 54.0), кажется, увеличивают масштаб по умолчанию, в то время как другие приложения этого не делают. Например, здесь у меня есть один и тот же файл изображения png, открытый в веб-браузере и в программе просмотра изображений: Как видно выше, изображение в веб-браузере (вставленное в файл […]

Используйте Firefox для загрузки страницы (на защищенном паролем сайте) каждые 15 минут

Я зашел на сайт через Firefox (пароли хранятся в менеджере паролей). Я хочу иметь возможность загружать страницу (недоступную без регистрации) каждые 15 минут для отслеживания определенной изменяющейся информации Сайт не предоставляет API, и я не хочу сохранять свой пароль где-либо еще. Есть ли аргумент командной строки, такой как wget >> myfile но firefox web-page >> […]

Debian: Невозможно запустить Firefox: libXcomposite.so.1: невозможно открыть файл общего объекта: нет такого файла или каталога

Я устанавливаю Firefox версии 36.0 на Debian 9.3 Первоначально я устанавливаю следующие 3 пакета: – xvfb – libdbus-glib-1-2 – imagemagick Затем я загрузил файл deb firefox-mozilla-build_36.0-0ubuntu1_amd64.deb И я устанавливаю это тогда. После завершения я пытаюсь запустить Firefox, но он дает мне ОШИБКУ: vagrant@packer-debian-9:~$ firefox XPCOMGlueLoad error for file /opt/firefox/libxul.so: libXcomposite.so.1: cannot open shared object file: […]