Tag: apt

Невозможно установить или загрузить что-либо в груше 8

Недавно я установил Pear OS 8 и с тех пор столкнулся с множеством проблем. По сути, я не могу ничего загрузить или установить. Сначала я получал сообщение об ошибке «не удалось загрузить информацию репозитория». Я попробовал sudo apt-get clean и sudo apt-get команды обновления, ни одна из которых не работала. Проведя больше исследований и попробовав […]

Как обновить сервер tomcat8 на ubuntu?

Я запускаю ubuntu xenial 16.04 . Запуск aptitude install tomcat8 приводит к версии tomcat 8.0.32 . Но текущий релиз – 8.0.46 . Как я могу принудительно установить или обновить aptitude именно с этой версией? aptitude versions tomcat8 отображаются только версии 8.0.32. Я хотел бы сохранить существующие конфигурации и приложения с v32, но хотел бы перейти […]

Связано с командой apt-get update

Я использую Ubuntu12.04, и я установил много pkg. Я хочу обновить только один конкретный pkg. Я попытался использовать $apt-get update pkgname E: The update command takes no arguments поэтому я попробовал $apt-get update все pkg успешно обновлены. Есть ли еще одна команда для обновления только одного конкретного pkg?

Как показать изменения для пакетов перед обновлением через apper или apt-get upgrade?

Очевидно, Debian 9.2 был выпущен сегодня, и благодаря этому Discover и Apper показывают множество пакетов, которые необходимо обновить. Я хочу просмотреть список изменений для всех этих пакетов перед запуском обновлений. Если возможно, я бы хотел, чтобы Apper / Discover проходил через пакеты (или пакетные пакеты) один за другим, чтобы он показывал мне журнал изменений (потенциально […]

Нечувствительные сообщения об ошибках для неудовлетворенных зависимостей в Debian Jessie

Моя проблема не в понимании сообщений об ошибках: она говорит, что I need blah-blah-1.49 (>= 1.49-1) and this is not installable но я уже установил blah-blah-1.55 . Я думаю, что 1.55 больше или равно 1.49.

Не удается установить программное обеспечение в Debian 6

Я установил Debian 6 Squeez на свою виртуальную машину, и я не могу установить программное обеспечение с помощью aptitude или apt-get . Это мой файл sources.list : root@debian:/etc/apt# cat sources.list # # deb cdrom:[Debian GNU/Linux 6.0.5 _Squeeze_ – Official i386 DVD Binary-1 20120512-13:45]/ squeeze contrib main deb cdrom:[Debian GNU/Linux 6.0.5 _Squeeze_ – Official i386 DVD […]

Установка apr (apt-get install libapr1-dev libssl-dev) в моей Linux-системе, дающей мне ошибки

Из-за некоторых проблем безопасности я перехожу к Apache 7 из Apache 6. Я пытаюсь установить apr-пакеты в свою Linux-машину. Я использую следующую команду для установки apr. apt-get install libapr1-dev libssl-dev что дает мне следующие ошибки: Reading package lists… Done Building dependency tree Reading state information… Done The following extra packages will be installed: libapr1 libssl-doc […]

Как я могу создать полный список файлов, установленных пакетом?

Я установил пакет geoip-bin с помощью команды apt-get : sudo apt-get install geoip-bin и я хотел знать команду командной строки для использования этого пакета. Но когда я пытаюсь перечислить файлы, которые пакет geoip-bin устанавливает, чтобы попытаться найти исполняемый файл, он не указан в выводе dpkg -S % dpkg -S geoip-bin geoip-bin: /usr/share/doc/geoip-bin/changelog.Debian.gz geoip-bin: /usr/share/lintian/overrides/geoip-bin geoip-bin: […]

Основной вопрос: Почему linux-образ не соответствует установленной версии?

Мне трудно найти ответ на это из Google. Я использую Debian Stretch (который я бесстыдно продвигаю как отличный опыт). Тем не менее, я заметил, что мое ядро ​​обновлялось с помощью основных команд apt upgrade . Эти обновления не были отражены в linux-изображении, полученном с помощью apt search linux-image или dpkg –list | grep linux-image dpkg […]

Почему я не могу установить libc6-dev-amd64, используя официальные онлайн-репозитории?

Я пытаюсь установить libc6-dev-amd64 на мой 64- libc6-dev-amd64 компьютер. Это мой файл sources.list: deb http://httpredir.debian.org/debian jessie main contrib non-free deb-src http://httpredir.debian.org/debian jessie main contrib non-free deb http://httpredir.debian.org/debian jessie-updates main contrib non-free deb-src http://httpredir.debian.org/debian jessie-updates main contrib non-free deb http://security.debian.org/ jessie/updates main contrib non-free deb-src http://security.debian.org/ jessie/updates main contrib non-free Когда я пытаюсь установить libc6-dev-amd64 , […]

Linux и Unix - лучшая ОС в мире.