Tag: apt

Установленный пакет, но получить более старую версию

Я обновил NodeJS, но версия по-прежнему отображается как старше. Что я делаю не так? Я вижу, что он загрузил последнюю версию (4.1.2). Заранее спасибо!

Как сделать apt-get install быстрее?

Я только что установил Debian впервые на виртуальной машине (я использовал centos / RHEL / fedora в течение последних 11 лет, поэтому у меня есть опыт Linux). Я сделал apt-get install gcc … команда заняла около 15 минут! Поскольку скорость загрузки составляла порядка 30 КБ / с (байты). Я тестировал свое соединение, и скорость загрузки […]

Можем ли мы установить пакет через сценарий оболочки?

Я пытаюсь написать сценарий оболочки, чтобы снова установить Ubuntu. Я мог бы просто запустить скрипт и сохранить все пакеты. И я планирую передать пароль в форме аргумента. Мой вопрос здесь в том, как я могу войти в домен sudo без ввода пароля вручную. Поскольку я также планирую разработать интерфейс, где он не может получить доступ […]

Что такое эквивалент Opensuse `apt-get source`?

В Debian я мог легко загрузить исходные источники для пакета с apt-get source . Я нашел это очень полезным для изучения программного обеспечения, которое я использую. Как я могу сделать что-то подобное в Opensuse? Самое близкое, что я нашел, это команда zyppre source-download соответствии с текстом справки о том, что он будет загружать источники для […]

Как понимать поле «Заменяет» в выводе «apt-cache зависит»?

Когда я запускаю apt-cache depends tar в моей установке Debian 8.3, тогда он говорит, что он заменит cpio : # apt-cache depends tar tar PreDepends: libacl1 PreDepends: libc6 PreDepends: libselinux1 Suggests: bzip2 Suggests: ncompress Suggests: xz-utils Suggests: tar-scripts Conflicts: cpio Breaks: dpkg-dev Replaces: cpio # Однако у меня установлены оба пакета cpio и tar : […]

libnss3 Обновление проблемы понижения

Я libnss3 на своем Ubuntu, чтобы установить Upwork программное обеспечение. Я успешно установил это программное обеспечение. Но после этого понижения, я не могу установить какое-либо другое программное обеспечение в своей системе. Я получаю следующую ошибку: Check if you are using third party repositories. If so disable them, since they are a common source of problems. […]

Как получить расположение каталога кеша apt?

Как узнать / узнать, где находится apt каталога кэша apt ?

Обновление mysql вызвало повреждение пакетов

У меня есть Debian Jessie и MySQL 5.6 из репозитория MySQL Debian . Эта установка устанавливает apt sources.list.d запись, которая после sudo apt-get install mysql-community-server , спрашивает, хочу ли я установить MySQL 5.6 или 5.7. Эта установка работает в течение нескольких месяцев. Сегодня я сделал sudo apt-get update && sudo apt-get upgrade . Это вызвало […]

Что делать, когда некоторые ошибки происходят во время процесса apt-get обновления?

Я случайно запустил apt-get update, apt-get dist-upgrade, прежде чем проверять свободное место на диске … Мало ли я знаю, что мой root / partition был заполнен до конца некоторыми ошибками журнала. Поэтому во время обновления я получил две ошибки: gdbm fatal: read error а также /usr/bin/mandb: can't write to /var/cache/man/26407: No space left on device […]

apt – опция командной строки 'i' не понята в сочетании с другими параметрами

Я делал сценарий оболочки, который устанавливает пакеты из списка. Код выглядит так: apps="$(cat ./foo/bar/packages.txt)" apt install $apps Но, я получаю ошибку E: Параметр командной строки 'i' [from -info] не понимается в сочетании с другими параметрами. Пакет packages.txt выглядит следующим образом: accountsservice acl acpi-support acpid … Заранее спасибо!

Linux и Unix - лучшая ОС в мире.