Tag: apt

Ошибка установки PostgreSQL в debian

Я пытаюсь установить PgSql в систему со следующими спецификациями: Distributor ID: Debian Description: Debian GNU/Linux 7.1 Release: 7.1 x86_64 Но я получаю такую ​​ошибку The following packages have unmet dependencies: postgresql-9.3 : Depends: libc6 (>= 2.15) but 2.13-38+deb7u1 is to be installed Как установить пропавший пакет? Я попробовал apt-get install libc6=2.13-38+deb7u1 и его показ libc6 […]

Crunchbang / Debian apt-preferences

Поэтому мне удалось настроить apt-предпочтения, но я не уверен, правильно ли я сделал это. Поэтому в основном я хочу, если у меня есть необходимость, я хочу установить пакеты из TESTING, UNSTABLE и DEB-MULTIMEDIA и что (ТОЛЬКО) эти Пакеты также получают обновления от конкретного Repo. Но в качестве «базы» я хочу иметь STABLE-Version. Было бы хорошо, […]

Apache 2.2, PHP 5.3 и MySQLl 5.5 на Linux Mint 17?

Наш стек состоит из Apache 2.2, PHP 5.3 и MySQL 5.5. Я установил Linux Mint 17 Giana. Если я установлю apache2 через apt , он установит Apache 2.4, который мне не нужен. Есть ли способ установить Apache 2.2 и PHP 5.3 через apt , изменив канонический репозиторий?

Загрузите yad с помощью скрипта bash

Я строю простой пакет deb (один бинарный) для небольшого проекта, над которым я работал. Теперь я хочу создать хороший интерфейс вокруг него и использовать zenity пару раз, но на этот раз я хотел использовать yad. Сначала я хочу загрузить yad, поэтому мой скрипт execuatble запускает файл gksudo с помощью gksudo , поэтому он запускается с […]

Как отключить сглаживание в git-gui и gitk

После обновления до Tcl / Tk 8.5, git-gui и gitk используют сглаженные шрифты, которые выглядят уродливо на моем дисплее. Я могу выбрать разные шрифты в диалоговом окне настроек, но шрифты, которые я использовал раньше (шрифты Helvetica и Courier bitmap), похоже, не отображаются в списке. Как восстановить предыдущие шрифты?

Исправьте версию debian по умолчанию для wheezy

Я выполнил этот учебник http://kemitix.postach.io/install-viber-on-debian-wheezy для установки viber на debian wheezy 7.6. Моя проблема заключается в той части, которая говорит: Исправьте версию по умолчанию для wheezy. Добавьте эту строку в /etc/apt/apt.conf.d/10release: APT :: Default-Release «wheezy»; Я пошел в /etc/apt/apt.conf.d/, но не было файла с 10-страницей, поэтому я создал его и добавляю строку. После этого я […]

как получить информацию. о разных версиях бинарного пакета, которые не находятся в /etc/apt/sources.list?

Я запускаю тестирование Debian / jessie с несколькими пакетами (могу рассчитывать на свои пальцы) из неустойчивого / sid и пары из экспериментальных (браузеров). Как выяснил Faheem, вот вывод политики apt-cache. $ apt-cache policy Package files: 100 /var/lib/dpkg/status release a=now 500 http://debian.ec.as6453.net/debian/ experimental/main Translation-en 500 http://debian.ec.as6453.net/debian/ experimental/contrib Translation-en 1 http://debian.ec.as6453.net/debian/ experimental/contrib amd64 Packages release o=Debian,a=experimental,n=experimental,l=Debian,c=contrib origin […]

установка libsocket-perl, apt-get ищет неправильное расширение имени файла, получает 404

У меня возникли проблемы с установкой пакета в течение нескольких дней, и я не могу найти решение нигде, хотя мне удалось более точно выяснить, что происходит. Похоже, apt-get или aptitude добавляет неправильное расширение в файл при поиске определенного пакета libsocket-perl в зеркале архива. Просматривая архив, я могу найти много версий пакета: http://ftp.us.debian.org/debian/pool/main/libs/libsocket-perl/ libsocket-perl_2.014-1+b2_s390x.deb libsocket-perl_2.014-1.debian.tar.xz libsocket-perl_2.014-1.dsc […]

Apt-get не работает в bash-скрипте?

У меня есть несколько машин (работает Ubuntu LTS 12.4 64-бит), которые нужно настроить одинаково, поэтому я создал сценарий оболочки, который будет запускаться автоматически при первом запуске машины. Он работает по большей части, но любой вызов apt-get терпит неудачу. В качестве примера, вот две команды, которые я хочу выполнить. debconf-set-selections ./files/ldap.preseed apt-get -y install ldap-auth-client Вот […]

Удаление компонентов Gnome с помощью Packagename

Я опробовал команды dpkg , aptitude и apt . На рабочем столе gnome я решил удалить один компонент. sudo apt-get remove gnome-games или что-то еще, все работает нормально. Но если я не знаю правильного имени пакета, у меня возникают проблемы. Это может помочь мне узнать PID. gnome-system-monitor Но теперь я также не знал правильного названия […]

Linux и Unix - лучшая ОС в мире.