Articles of apt

Как установить функциональный набор инструментов ARM cross-gcc в Ubuntu 18.04?

контекст Я недавно установил Ubuntu 18.04, Linux foobar-VirtualBox 4.15.0-23-generic #25-Ubuntu SMP Wed May 23 18:02:16 UTC 2018 x86_64 x86_64 x86_64 GNU/Linux на виртуальной Ubuntu 18.04, Linux foobar-VirtualBox 4.15.0-23-generic #25-Ubuntu SMP Wed May 23 18:02:16 UTC 2018 x86_64 x86_64 x86_64 GNU/Linux . Я хочу кросс-компилировать приложения для процессоров Cortex-M4F с жесткими плавающими точками , поэтому я […]

Почему я получаю 404 Not Found при добавлении этого хранилища в /etc/apt/sources.list?

В моем файле /etc/apt/sources.list : deb http://debian.ruc.dk/rumd stretch main deb-src http://debian.ruc.dk/rumd stretch main Когда я запускаю sudo apt update я вижу Ign:10 http://debian.ruc.dk/rumd stretch InRelease Hit:11 http://dl.google.com/linux/chrome/deb stable Release Err:12 http://debian.ruc.dk/rumd stretch Release 404 Not Found E: The repository ‘http://debian.ruc.dk/rumd stretch Release’ does not have a Release file. РЕДАКТИРОВАТЬ: Похоже, ошибка в том, что нет […]

Apache2 автоматически устанавливается при установке PHP 7.2?

Кто-нибудь еще испытывает эту проблему? Когда я установил PHP 7.2, он как-то автоматически установил Apache2 вместе с ним. Это новая версия Ubuntu 16.04, на которой установлен только nginx для обслуживания статических файлов. add-apt-repository ppa:ondrej/php apt-get update apt-get install php7.2 apt-get install php-pear php7.2-curl php7.2-dev php7.2-gd php7.2-mbstring php7.2-zip php7.2-mysql php7.2-xml Я узнал об этом только после […]

Какое разрешение мне здесь не хватает?

Я пытаюсь загрузить пакет ffmpeg и все его зависимости в каталог на моем компьютере. Я использую этот код, чтобы сделать это sudo apt-get download $(apt-rdepends ffmpeg|grep -v “^ “) Это работает по большей части, пока не столкнется с этим: W: Can’t drop privileges for downloading as file ‘/home/daslab/compression/downloaded/ffmpeg2/ffmpeg2theora_0.30-1_amd64.deb’ couldn’t be accessed by user ‘_apt’. – […]

Растяжение Debian 9.4 – неудовлетворенные зависимости

Я пытаюсь запустить игровой сервер с использованием SRCDS, но всякий раз, когда я пытаюсь получить зависимости с помощью этой команды: sudo dpkg –add-architecture i386; sudo apt update; sudo apt -f install mailutils postfix curl wget file bzip2 gzip unzip bsdmainutils python util-linux ca-certificates binutils bc tmux lib32gcc1 libstdc++6 libstdc++6:i386 lib32tinfo5 Я получаю следующую ошибку: Некоторые […]

Как узнать имена переменных для debconf-set-selections?

Допустим, я хочу установить mysql из сценария, не задавая никаких вопросов о конфигурации, например, какой пароль root я хочу установить с помощью apt . Затем я бы установил переменные debconf : echo mysql-server-5.5 mysql-server/root_password password xyzzy | debconf-set-selections echo mysql-server-5.5 mysql-server/root_password_again password xyzzy | debconf-set-selections Я получил это из учебника. Что мне неясно: как парень […]

Как мне открепить пакет, прикрепленный с помощью apt-listbugs

Я получил binutils, закрепленный apt-listbugs – /etc/apt/preferences.d$ cat apt-listbugs Explanation: Pinned by apt-listbugs at 2018-03-25 06:42:33 +0530 Explanation: #852035: binutils: bfd stumbles over duplicated symbols generated by gold Explanation: #852671: libkf5kipi: FTBFS (linking error) Explanation: #852672: libqapt: FTBFS (linking error) Explanation: #852899: libkf5kipi: FTBFS: libQt5Gui.so.5.7.1:(*IND*+0x0): multiple definition of `__bss_start’ Explanation: #852909: libqapt: FTBFS: libQt5Gui.so.5.7.1:(*IND*+0x0): multiple […]

Невозможно установить i3 на растяжение Debian

Я хотел бы попробовать оконный менеджер i3. Когда я запускаю apt-get install i3 я сталкиваюсь со следующей ошибкой; root@hammerhead:~# apt-get install i3 Reading package lists… Done Building dependency tree Reading state information… Done E: Unable to locate package i3 Вот копия /etc/apt/sources.list ; root@hammerhead:~# cat /etc/apt/sources.list # deb cdrom:[Debian GNU/Linux 9.3.0 _Stretch_ – Official amd64 […]

Установка сервера Percona XtraDB Cluster

Я хочу установить серверный пакет Ubuntu 16.04.4 LTS XtraDB Cluster в Ubuntu 16.04.4 LTS но я получил эту ошибку: sudo apt-get install percona-xtradb-cluster-57 Reading package lists… Done Building dependency tree Reading state information… Done E: Unable to locate package percona-xtradb-cluster-57

Небезопасное хранилище: Ксениал Бодхи?

Заклинило установкой Бодхи на старый MacBook. Запуск обновлений выдает ошибку, насколько я помню, что сам repository Xenial Bodhi был незащищен из-за отсутствия шифрования. Я сейчас перезагружаюсь при изменении размера разделов. Возможно, похоже на https://askubuntu.com/q/732985/45156 : W: GPG error: http://www.deb-multimedia.org jessie InRelease: The following signatures couldn’t be verified because the public key is not available: NO_PUBKEY […]