Tag: Разработка

./configure: Нет такого файла или каталога в GCC

Я пытаюсь сделать работу после osdev.org. Однако я не могу этого сделать без режима кросс-компилятора в gcc. Я пытаюсь изменить параметр host на i686-elf-gcc (это, предположительно, активирует режим cc для этой платформы), но для этого я должен запустить ./configure . Когда я это сделаю, я получаю эту ошибку: ./configure: No such file or directory. Что […]

Сопоставимый редактор для gedit с меньшими зависимостями?

Я хочу оставить Gnome и установить awesome на debian squeeze или wheezy, но я действительно не могу работать без gedit. Есть ли какой-либо текстовый редактор, такой как gedit, способный редактировать столбцы, выделяя почти любой язык и создавая текс-файлы прямо из редактора? Богатство функций важно для меня, потому что я хочу использовать его как центральную «IDE». […]

Подготовка установки Ubuntu для совместного использования

У меня есть виртуальная версия Ubuntu, работающая в VirtualBox. В настоящее время у меня много личной информации. Я хочу поделиться диском виртуального образа с другими разработчиками, но я не хочу, чтобы они могли получить всю мою личную информацию. Что я должен удалить, прежде чем распространять этот vm другим разработчикам? Я удалил все старые проекты и […]

Как заставить Pycharm распознавать и использовать библиотеки Python 3.6.1?

То же, что и выше. Недавно я сломал свою систему, а затем вытер и переустановил. Сначала мне удалось получить python 3.6, работающий в Pycharm с новым установленным, прежде чем снова сломать вещи. Я не делал ничего особенного и просто возвращал свои шаги только для того, чтобы найти Pycharm, увидев только 2.7 и 3.5 вместо 3.6 […]

Где отбрасывать библиотеки в соответствии со стандартом иерархии файловой системы

Я использую систему сборки на базе Linux. Сама система сборки основана на сценариях Jenkins, Nexus, Maven, Ant и Shell. Некоторые проекты нуждаются в некоторых специальных инструментах и ​​библиотеках для строительства. В частности, у нас есть некоторые Ant-Tasks, которые нужны только двум проектам, и мы не хотим отбрасывать эти задачи в папку ant. Какова ваша рекомендация […]

Python в базе кода GNOME

Является ли Python присутствующим в базе кода Gnome? Если да, то как это связано? Примечание . Мой вопрос касается только основной среды GNOME (например, nautilus , gnome-session , NetworkManager ) и любого базового приложения или библиотеки.

Nginx на Debian 8 dev setup. PHP через PHP FPM не работает

UPDATE: Хорошо, теперь я могу с радостью сказать, что то, что вы видите ниже, – это рецепт для счастливой работы автоматизированной установки PHP и Nginx dev (с автоматическими доменами), и все проблемы, которые у меня были, теперь решены. Я установил следующее: sudo apt-get nginx php5 php5-fpm dnsmasq на Debian 8, Jessie. Я установил dnsmasq, чтобы […]

Libreoffice Calc – Можете ли вы сохранить код VBA после просмотра и редактирования, поэтому он сохраняется в следующий раз, когда к файлу обращаются?

Я разрабатываю, используя VBA в Libreoffice Calc. Я узнал, экспериментируя, что он может читать vbaproject в файле .xlsm . Я смог прочитать макросы в vbaproject, который я создал через Excel, сохранил этот файл как .xls файл после редактирования, затем закрыл файл, а затем Calc. Я ожидал, что новый файл будет сохранен с изменениями, но при […]

Почему у меня так много версий python на моем mac?

Я хотел бы получить в scipy и сначала настроить мой macbook воздух для разработки python. Проблема в том, что у меня установлено много разных версий python – вот что я получаю, когда bash autocompletes «pyth» : python python2.6-config python3-config python3.4m-config python-config python2.7 python3.4 pythonw python2 python2.7-config python3.4-32 pythonw2 python2-config python3 python3.4-config pythonw2.6 python2.6 python3-32 python3.4m […]

Установка средств разработки в RHEL 6

У меня есть привилегия администратора на моем офисном компьютере (работает RHEL 6), который подключен в сети. Я пытался установить средства разработки с помощью команды: sudo yum groupinstall "Development Tools" но я получил сообщение об ошибке: Updating certificate-based repositories. There was an error communicating with RHN. RHN Satellite or RHN Classic support will be disabled. Error […]

Linux и Unix - лучшая ОС в мире.