Tag: зависимостей

Почему ./configure дает мне неудовлетворенные пакеты, которых не существует?

Я пытаюсь скомпилировать Caribou 0.4.18.1 на Xubuntu 14.04 . В документе INSTALL говорится, что я должен запустить ./configure && make && make install . Но шаг ./configure завершился: checking for python platform… linux2 checking for python script directory… ${prefix}/lib/python2.7/dist-packages checking for python extension module directory… ${exec_prefix}/lib/python2.7/dist-packages checking for CARIBOU… no configure: error: Package requirements ( […]

Tor установить на CentOS-сервер

Я выполнил приведенные здесь инструкции: https://www.torproject.org/docs/rpms.html.en Однако при запуске yum install tor я получаю следующую ошибку зависимостей: Error: Package: tor-0.2.5.10-tor.2.rh7_0_1406.x86_64 (tor) Requires: libevent-2.0.so.5()(64bit) Затем я приступаю к установке libevent. По какой-то причине я не получаю правильную версию от yum, поэтому мне нужно загрузить библиотеку libevent с http://libevent.org/ и запустить следующее: ./configure –prefix=/opt/libevent make make install […]

Как определить зависимости для пакета

Прежде чем создать PKGBUILD, я всегда проверяю необходимые библиотеки приложения с помощью утилиты ldd. Разработчики программного обеспечения часто пропускают необходимые пакеты из своих файлов README / INSTALL, а имена пакетов часто различаются между дистрибутивами. Некоторые пакеты могут потребоваться в одном дистрибутиве, но в других дистрибутивах они не нужны. Я нашел ldd бесценным для определения основного […]

Невозможно скомпилировать WiredTiger с быстрой поддержкой под rhel

Мне нужно использовать WiredTiger командной строки WiredTiger для манипулирования данными MongoDB . Я получил источники из http://source.wiredtiger.com/ и побежал ./configure –enable-snappy . Получена следующая ошибка configure: error: –enable-snappy requires snappy.h Я клонировал https://github.com/google/snappy.git в подкаталог и соответственно установил CPATH export CPATH=/home/mongod/termit/wiredtiger-2.9.2/snappy Теперь он находит файлы заголовков, но я получаю эту ошибку configure: error: –enable-snappy requires […]

Какая программа использует какой пакет?

Обновление моего Linux-сервера в основном является напряженной частью для меня. Как сегодня. С обновлением yum я вижу новую версию NodeJS, но из того, что я помню, nodejs был использован программой, которую нужно тщательно изменить. Поэтому я подумал, должна быть команда, как узнать, какая программа использует NodeJS, но, к сожалению, я не могу найти такую ​​команду. […]

Построение программного обеспечения из источника по рассыпному распределению

В скользящем выпуске дистрибутива, таком как openSUSE Tumbleweed, если нужно создать какое-то программное обеспечение из источника, как часто эти программы нужно будет перестроить, учитывая, что зависимости, установленные из репозиториев распространения, могут часто обновляться. Например, если кто-то хотел создать Apache httpd и Exim из источника, оба из которых могли бы зависеть от PCRE и GnuTLS, между […]

Как я могу установить все отсутствующие библиотеки perl?

Я пытаюсь установить logitechmediaserver 7.8.0 на моем OSMC (Raspbmc) Raspberry Pi. Я в первую очередь следил за инструкциями отсюда , хотя некоторые из них не работали (некоторые зависимости отсутствовали в репозиториях, а исправление не удалось). Независимо от того, я попал в ту часть, где я перезапускаю сервер с помощью sudo service logitechmediaserver start , а […]

Неудачные зависимости

Я ищу следующее: libpython2.5.so.1.0 libtinfo.so.5 python (abi) = 2.5 Я искал, но я не могу их найти. Я запускаю Centos 5.6 с linux kernel 2.6.18-238.el5. $ rpm -q –provides python | grep -Fw 'python(abi)' python(abi) = 2.4 Насколько я искал, libtinfo.so.5 теперь является частью библиотеки ncurses. Но он ищет определенную библиотеку dependecy. Моя текущая версия […]

зачем нужен пакет qt4 для запуска vlc-плеера?

Я установил arch linux. В качестве видеопроигрывателя я выбираю vlc. Я не смог запустить vlc, если я не установил пакет qt4. Зачем это нужно? Если мы не сможем запустить vlc без qt4 pkg, почему он не установлен вместе с vlc. Может ли кто-нибудь помочь мне понять это?

Удалять только неиспользуемые зависимости, используя Synaptic

Как и все дистрибутивы, установите много неиспользуемого программного обеспечения, так же как и PCLinuxOS. Но когда я пытаюсь удалить это программное обеспечение с помощью Synaptic, он отмечает зависимости как «удаляемые». Проблема в том, что эти зависимости используются в других частях программного обеспечения. Например, я хочу удалить игрока KDE Dragon, и когда я его помечаю для […]

Linux и Unix - лучшая ОС в мире.