Articles of библиотеки

Файлы библиотеки не найдены, хотя они указаны в файле ldconfig

Это головной скребок. Ниже приведен вывод ldconfig -p | grep libncur* ldconfig -p | grep libncur* : libncursesw.so.5 (libc6,x86-64) => /usr/lib64/libncursesw.so.5 libncursesw.so (libc6,x86-64) => /usr/lib64/libncursesw.so libncurses.so.5 (libc6,x86-64) => /usr/lib/libncurses.so.5 libncurses.so.5 (libc6,x86-64) => /usr/lib64/libncurses.so.5 libncurses.so.5 (libc6,x86-64) => /lib/libncurses.so.5 libncurses.so (libc6,x86-64) => /usr/lib64/libncurses.so Это ошибка, которую я получаю: /cass/bin/m050ub02: error while loading shared libraries: libncurses.so.5: cannot open […]

Миграция библиотек

У меня есть одна предварительно скомпилированная разделяемая библиотека, для которой требуется GLIBC-2.9 Но я хочу использовать ее против GLIBC-2.8. Я очень уверен, исходный код не использовал никакой функции, которая вводилась в 2.9 Поскольку библиотека закрыта, я не могу загрузить исходный код и скомпилировать его в желаемую среду. Есть ли способ использовать предварительно скомпилированную библиотеку в […]

есть ли libboost-all вместо libboost-all-dev?

Мне нужна зависимость libboost для пакета, который я запускаю, но единственный пакет, который я могу найти, это libboost-all-dev , и я не уверен, что означает «dev», и если мне это нужно. Есть ли libboost-all-<Something> который мне нужно установить вместо этого?

Экспериментальный пакет Debian отказывается устанавливать?

Я продолжаю получать эту ошибку: ./binary: /lib/x86_64-linux-gnu/libc.so.6: version `GLIBC_2.14' not found (required by ./binary) Я попробовал инструкции здесь: https://superuser.com/questions/537683/how-to-fix-lib-x86-64-linux-gnu-libc-so-6-version-glibc-2-14-not-found Но когда я запускаю sudo apt-get -t experimental install libc6 он говорит, что самая новая версия уже установлена, хотя это явно не потому, что: а) я просто добавил экспериментальные, и б) я все равно получаю ту […]

Каковы недостатки uClibc?

Я пытаюсь ускорить загрузку, и кто-то рекомендует использовать uClibc вместо Glibc. Я создал изображение с ним, он становится все меньше и быстрее для загрузки – но по какой цене? Кто-нибудь знает недостатки использования uClibc в качестве библиотеки C?

задать путь библиотеки для текущего скрипта

Как установить путь библиотеки для текущего скрипта? Я имею в виду, что я не хочу перечислять новый путь для библиотек в текстовом файле. Я попробовал это, используя export LD_LIBRARY_PATH=$(pwd)/lib/ Это сценарий: #!/bin/bash LD_LIBRARY_PATH="$(pwd)/lib/" export LD_LIBRARY_PATH ./X3TC_config

проблема с пакетами R на linux

Почему я должен почти всегда устанавливать библиотеки и не могу установить пакет R напрямую, как в Windows? При установке пакета с именем Hyfo мне нужно установить библиотеки трех разных зависимостей вручную. Мне нужно много времени искать имя библиотек для установки, чтобы я мог правильно установить Hyfo. Например, для пакета rgdal: sudo apt-get install libgdal-dev libproj-dev […]

Как установить libtoolize

Я пытаюсь установить программное обеспечение, и autoreconf терпит неудачу, потому что libtoolize не установлен в моей системе. У меня нет корневого доступа к этой системе, но мне нужно установить libtoolize. Как установить libtoolize? Какой пакет исходного кода предоставляет это?

OBS Studio CMAKE не может найти FFmpeg?

Я пытаюсь установить OBS Studio на Debian 8. Я пытался следовать официальному руководству по установке для OBS Studio, но когда я пытаюсь запустить cmake -DUNIX_STRUCTURE=1 DCMAKE_INSTALL_PREFIX=/usr .. Я получаю следующую ошибку: — OBS_VERSION: 18.0.1-12-g3540e71 CMake Error at /usr/share/cmake-3.0/Modules/FindPackageHandleStandardArgs.cmake:136 (message): Could NOT find FFmpeg (missing: FFMPEG_AVCODEC_LIBRARIES FFMPEG_AVCODEC_INCLUDE_DIRS avcodec avfilter avdevice avutil swscale avformat swresample) Call Stack […]

Удалить библиотеку, установленную через make install

Я установил библиотеку, скомпилированную из исходного кода, через make install в /usr/local/ Теперь я узнал, что это была плохая идея (конфликтующие файлы и т. Д.) И хотелось бы отменить это действие. Пакет не предусматривает make uninstall . Возможно ли это, без переустановки всей ОС? В настоящее время работает ОС Tumbleweed.