Articles of пакетное управление

Полуустановленный пакет кошмар – как исправить?

Я недавно (пытался) обновить систему Linux Mint (18.3, x64). Все прошло нормально, но я получил ошибку с помощью скриптов конфигурации для linux-image-extra-4.13.0-41-generic и linux-image-extra-4.13.0-41-generic . Некоторое время я мог устанавливать другие пакеты, но после попытки удалить их, я больше не мог ничего устанавливать. Чтобы удалить их, я попытался: sudo apt remove linux-image-extra-4.13.0-41-generic linux-image-extra-4.13.0-41-generic sudo apt […]

Alpine Linux Apk Add дает временную ошибку

В то время как инструмент давал много ошибок, мы решили восстановить сервер. Однако в процессе автоматической сборки произошла следующая ошибка: ERROR: pkgconf-1.3.10-r0: temporary error (try again later) Теперь это не единственная строка, каждый пакет, который будет установлен, дал эту временную ошибку. Даже попытка установки пакетов вручную выдает эту ошибку, когда я просто пытался установить bash: […]

Как я могу установить и запустить конфликтующие пакеты в Debian / Ubuntu?

Я хотел бы установить python3.7 и idle-python3.7 на мою stable idle-python3.7 Debian, но они из sid и требуют более новых версий libc , что потребует обновления загрузок и загрузок основных пакетов до нестабильных версий, если я сделаю это нормальный способ . Кроме того, это потребовало бы обновления или удаления большого количества пакетов, которые по какой-либо […]

Как пометить пакет, чтобы предотвратить установку

Я обнаружил несколько пакетов, которые нарушают мою конфигурацию (например, light-locker , evince и т. Д.) Как я могу предотвратить установку этих пакетов через apt-get install в моей системе (Debian) с указанием причины ошибки?

Почему нельзя добавить угрозу в список sources.list?

Чтобы установить Sublime, он хочет, чтобы я добавил ключ GPG и запись sources.list, чтобы apt-get мог его найти. Несколько других программ просили то же самое. Почему не добавление доменов в sources.list не является угрозой безопасности? То есть: предположим, что пакет A должен исходить от хоста B. Я добавляю хост C в новый список sources.list. Хост […]

dpkg – проблемы с зависимостью препятствуют удалению цитадели

Я хотел бы удалить цитадель из моей машины. Я следую за этими шагами для Debian (не EasyInstall): Удалить цитадель Хауэбер, я получаю эти ошибки: dpkg: warning: ignoring request to remove citadel-client which isn’t installed dpkg: warning: ignoring request to remove citadel-mta which isn’t installed dpkg: dependency problems prevent removal of citadel-server: bsd-mailx depends on default-mta […]

Отсутствует исполняемый файл cc1 в Amazon Linux

Я пытался собрать Tensorflow на Amazon Linux (2016.09). Я cc1 с невозможностью получить cc1 для установки с GCC. Вот что я попробовал: Установка gcc Установка gcc-c++ Установка определенных версий выше (например, 4.8.5) Группа установки “Development Tools” Проверка /usr/libexec/gcc/x86_64-amazon-linux/[version] чтобы увидеть, есть ли исполняемый файл cc1 и его нужно просто добавить в мой PATH . Я […]

Заполнители dpkg-запроса «Filename», «MD5sum» и «Size» всегда пусты

В настоящее время я пытаюсь получить некоторую информацию об установленных пакетах и ​​системах, которые используют dpkg . Поэтому я попытался использовать dpkg-query . Большинство заполнителей работают нормально, и я получаю то, что мне нужно, однако я заметил, что заполнители Filename , MD5sum и Size всегда пусты. Простая команда, чтобы увидеть проблему: dpkg-query -W -f ‘”location”:”${Filename}”,”md5″:”${MD5sum}”,”size”:”${Size}”\\n’ […]

Как обновить openssl 1.0.1 в Debian

TL; DR: я пытаюсь установить пакет, который требует libssl 1.0.2 или выше, но не может: # dpkg -i my_package_name_3.0.1.8_amd64.deb Selecting previously unselected package my_package_name. (Reading database … 266120 files and directories currently installed.) Preparing to unpack my_package_name_3.0.1.8_amd64.deb … Unpacking my_package_name (3.0.1.8) … dpkg: dependency problems prevent configuration of my_package_name: my_package_name depends on libssl1.0.0 (>= 1.0.2g); […]

Локомотив не работает в системе Debian: sl ls

ПРОБЛЕМА: Я установил sl но когда я sl в командной строке, я получаю это: bash: sl: command not found (root@host)-(03:55:38)-(/home/user) $apt install sl Reading package lists… Done Building dependency tree Reading state information… Done sl is already the newest version (3.03-17+b2). 0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded. Sl – […]

Intereting Posts
Определение частоты дискретизации на ALSA NTPd не синхронизируется на RaspberryPi Трейлинг пространства при генерации md5 BIND9, отклоняющий запросы от IP-адресов outsite localnet (внешние IP-адреса) – Ubuntu 14.04 Завершение команды не работает с именами, содержащими `:` Как отображать мои данные (молекулы)? Скопируйте файлы из папки, если они также находятся в другой папке заголовок сценария оболочки для лучшей совместимости Как указать регулярное выражение для аргументов команды в sudoers Делает ли / proc / net / udp все капли, которые происходят между подключением Ethernet и моим приложением? Разрешить пользователю SFTP только конкретную корневую директорию Linux эффективная команда, чтобы найти, если 32 бит / 64 бит Linux Mint 12: версия для DVD и версия для компакт-дисков Как получить время в формате HHMM несколько минут, следовательно, сейчас? понимание терминологии .sh файлов и cmake