Intereting Posts
Выход прерывается при добавлении вывода sql-запроса в ksh Редактор PDF с регулярными выражениями для закладок? разделить большой файл на новый файл с уникальными именами файлов Каковы последствия отсутствия действительной таблицы разделов? Почему имя хоста –fqdn возвращает только имя домена? Поиск идентификатора процесса и его уничтожение logrotate работает при запуске вручную, не выполняется при запуске cron Зачем компилировать несколько файлов .cpp в один и тот же исполняемый файл? Обновления Google Chrome после 32-битного прекращения Один пользователь для совместного использования или нескольких пользователей Запуск приложения Qt при запуске для встроенной Linux Установка изображения частичного изображения Как скомпилировать C-код с библиотекой «Unix network book book»? Что происходит, когда несколько процессов пытаются mv одни и те же файлы между двумя различными файловыми системами Введите пароль в SSH без ввода

libnss3 Обновление проблемы понижения

Я libnss3 на своем Ubuntu, чтобы установить Upwork программное обеспечение. Я успешно установил это программное обеспечение. Но после этого понижения, я не могу установить какое-либо другое программное обеспечение в своей системе.

Я получаю следующую ошибку:

 Check if you are using third party repositories. If so disable them, since they are a common source of problems. Furthermore run the following command in a Terminal: apt-get install -f The following packages have unmet dependencies: aptitude: Depends: libapt-pkg4.12 (>= 0.8.16~exp12ubuntu6) but 1.0.1ubuntu2.11 is installed Depends: libboost-iostreams1.46.1 (>= 1.46.1-1) but it is not installed Depends: libc6 (>= 2.4) but 2.19-0ubuntu6.7 is installed Depends: libcwidget3 but it is not installed Depends: libept1.4.12 but it is not installed Depends: libgcc1 (>= 1:4.1.1) but 1:4.9.3-0ubuntu4 is installed Depends: libncursesw5 (>= 5.6+20070908) but 5.9+20140118-1ubuntu1 is installed Depends: libsigc++-2.0-0c2a (>= 2.0.2) but 2.2.10-0.2ubuntu2 is installed Depends: libsqlite3-0 (>= 3.6.5) but 3.8.2-1ubuntu2.1 is installed Depends: libstdc++6 (>= 4.6) but 4.8.4-2ubuntu1~14.04.1 is installed libnss3-nssdb: Depends: libnss3 (= 2:3.21-0ubuntu0.14.04.2) but 2:3.19.2-1ubuntu1 is installed 

Примечание . Это общий совет для любого приложения, которое требует более ранней, замененной или иным образом эксцентричной библиотеки. Библиотека libnss3 и приложение для работы с ними являются прекрасными примерами.

1. Исправьте систему

ОК, во-первых, отмените то, что вы сделали. Если вы использовали любой apt-pin, то удалите их (для libnss3), а затем выполните:

 apt-get install libnss3 aptitude update; aptitude safe-upgrade 

Затем проверьте, установлена ​​ли последняя версия:

 apt-cache policy libnss3 

или

 dpkg-query -l libnss3 

Правильно, ваша система снова работает правильно.

2. Приступайте к работе

Затем запустите рабочую программу. Во-первых, отдельно загрузите более раннюю версию libnss3 и поместите эту более раннюю версию с пониженным рейтингом в другой каталог. Я на debian, поэтому я получил стабильный пакет с https://packages.debian.org/jessie/libnss3 . Место для таких библиотек находится в / usr / local / lib / someDir /. Как только файл thelibnss3_3.17.2-1.1 + deb8u2_i386.deb (скажем) находится в этом каталоге или в каталоге temp, извлеките из него его содержимое:

 dpkg-deb -x libnss3_3.17.2-1.1+deb8u2_i386.deb 

и переместите библиотеки libnss3 в / usr / local / lib / someDir /

 mv <extractDir>/usr/lib/i386-linux-gnu/nss/* /usr/local/lib/someDir/ 

которые могут быть

 mv /usr/local/lib/someDir/usr/lib/i386-linux-gnu/nss/* /usr/local/lib/someDir/ 

Теперь у вас есть пониженные библиотеки в отдельном каталоге. Теперь вам просто нужно, чтобы приложение upwork использовало эти библиотеки.

 export LD_LIBRARY_NAME=/usr/local/lib/someDir:$LD_LIBRARY_NAME upwork 

Лучшее решение – создать короткий скрипт под названием / usr / local / bin / upwork (да, точно такое же имя), а затем обеспечить (да, убедитесь), что / usr / local / bin / находится в вас $ PATH до / usr / бен. Этот короткий сценарий будет включать

 export LD_LIBRARY_PATH=/usr/local/lib/someDir:$LD_LIBRARY_PATH /usr/bin/upwork 2 >& 1 & 

сделать исполняемый файл сценария

 chmod 755 /usr/local/bin/upwork 

Ваше приложение upwork теперь будет использовать эти пониженные библиотеки libnss3.

Хорошо, поэтому после многого поиска, что я решил. В папке dpkg у меня есть файл с именем lock. Я изменил разрешение файла, а также папку dpkg. Затем я запускаю

 apt-get install -f 

теперь я смогу установить любое программное обеспечение.