Ldap SSH Login не работает – одинаковые конфигурации работают на 20+ других серверах – Ubuntu

Поэтому у меня есть настройка LDAP Login на каждом сервере при моей работе, кроме одного. Конечно, должен быть тот! И я хочу закрыть свой билет на jira, но я не могу понять, в чем проблема. Система представляет собой Ubuntu 10 x32

Вот результат работы auth.log

Oct 29 10:56:33 localhost sshd[2560]: Invalid user LDAPUSERNAME from 10.1.11.224 Oct 29 10:56:33 localhost sshd[2560]: Failed none for invalid user LDAPUSERNAME from 10.1.11.224 port 51830 ssh2 Oct 29 10:56:36 localhost sshd[2560]: pam_unix(sshd:auth): check pass; user unknown Oct 29 10:56:36 localhost sshd[2560]: pam_unix(sshd:auth): authentication failure; logname= uid=0 euid=0 tty=ssh ruser= rhost=10.1.11.224 Oct 29 10:56:36 localhost sshd[2560]: pam_ldap: error trying to bind as user "uid=LDAPUSERNAME,ou=People,dc=DOMAIN,dc=com" (Invalid credentials) Oct 29 10:56:38 localhost sshd[2560]: Failed password for invalid user LDAPUSERNAME from 10.1.11.224 port 51830 ssh2 

UPDATE: это успешный вход на другой сервер, а выход auth.log

 Oct 29 11:23:56 daily sshd[20625]: pam_unix(sshd:auth): authentication failure; logname= uid=0 euid=0 tty=ssh ruser= rhost=10.1.11.224 user=LDAPUSERNAME Oct 29 11:23:56 daily sshd[20625]: Accepted password for LDAPUSERNAME from 10.1.11.224 port 52211 ssh2 Oct 29 11:23:56 daily sshd[20625]: pam_unix(sshd:session): session opened for user LDAPUSERNAME by (uid=0) 

По какой-либо причине аутентификация на сервере LDAP не выполняется (не аутентификация пользователя):

Oct 29 10:56:36 localhost sshd [2560]: pam_ldap: ошибка пытается связать как пользователь «uid = LDAPUSERNAME, ou = Люди, dc = DOMAIN, dc = com» (Недействительные учетные данные)

Как вы выполняете аутентификацию на сервере LDAP, попробуйте установить pam_ldap debug 9 в строку pam_ldap чтобы получить дополнительную информацию. Сравнение с тем же, что и на рабочем сервере, может принести еще несколько идей.

Кроме того, запуск вручную ldapsearch может вызвать некоторые ошибки в конфигурации.

По какой-то причине /etc/nslcd.conf не был создан во время установки. Я скопировал его с другого сервера Ubuntu 10, который работал с настройкой LDAP, но он не запускался из-за строки >>

 #nss_initgroups_ignoreusers ALLLOCAL 

Что странно, потому что на другом сервере Ubuntu 10, который я настраиваю также с теми же конфигурациями, но thats linux. Несмотря на это, (я прокомментировал это) его работа сейчас!