KDE 5 из Debian Jessie – какая версия Qt была использована для ее компиляции?

Недавно я вернулся в Windows из-за несовместимости настольных компьютеров Linux с высоким разрешением (UHD) и сенсорных экранов. Поскольку теперь это стало намного лучше, чем раньше, я бы хотел вернуться в Linux, поскольку Windows действительно сводит меня с ума.

Тем не менее, хотя я знаю, что Gnome поддерживает сенсорный режим и высокое разрешение, я хотел бы знать, поддерживается ли он в KDE. Теперь, когда KDE скомпилирован с Qt, я знаю, что Qt предоставил исправление для high-res с переменной окружения qt_device_pixel_ratio , и я могу представить, что настройка, которая будет правильно масштабировать все в KDE, так как она работает со всем остальным.

Это исправление работает только с версией Qt> = 5.4. Поэтому, прежде чем продолжить, мне нужно знать, какая версия Qt использовалась для компиляции пакета KDE 5 в Debian Jessie. Как я могу это знать?

Примечание. Я хотел бы избежать ручного масштабирования шрифтов и окон DPI, поскольку это не так приятно.

Это также хорошо для меня, чтобы узнать, как следить за зависимостями на сайте debian, поскольку я не совсем понял, как это сделать на веб-сайте repos Debian.

Заранее спасибо.

Qt 5 построен в qtbase-opensource-src в Debian. На странице связанного трекера показано, что версия в Jessie ( stable ) равна 5.3.2 + dfsg-4-deb8u1 , поэтому в основном 5.3.2, которая старше 5.4 …

5.4 доступен в Stretch (следующая версия Debian, в настоящее время находится в разработке), а 5.5 находится в experimental (своего рода промежуточная область для пакетов, которые нуждаются в тестировании, но пока не считаются пригодными для стабильной версии дистрибутива).

Обнаружив это, просмотрев зависимости (начиная с meta-kde , пакета KDE самого высокого уровня) довольно сложно, так как большая часть KDE в Debian по-прежнему построена с Qt 4. Я действительно искал библиотеки Qt 5 в aptitude и работал путь оттуда.