Проблема установки JDT в Eclipse на Linux

Я установил Eclipse на Fedora Core 14 с помощью yum install eclipse-platform . Я запустил eclipse и попытался установить инструменты разработки java, но затем эта ошибка возникла:

 Cannot complete the install because of a conflicting dependency. Software being installed: Eclipse Java Development Tools 3.6.2.r362_v20101117-0800-7z8XFW6FLFlmjJcvz03jyeFBLS_F (org.eclipse.jdt.feature.group 3.6.2.r362_v20101117-0800-7z8XFW6FLFlmjJcvz03jyeFBLS_F) Software currently installed: Eclipse Platform 3.6.1 (Eclipse Platform 3.6.1) Only one of the following can be installed at once: Eclipse IDE UI 3.6.1.M20100825-0800 (org.eclipse.ui.ide 3.6.1.M20100825-0800) Eclipse IDE UI 3.6.0.I20100601-0800 (org.eclipse.ui.ide 3.6.0.I20100601-0800) Eclipse IDE UI 3.6.2.M20101201-0800 (org.eclipse.ui.ide 3.6.2.M20101201-0800) Cannot satisfy dependency: From: Eclipse Platform 3.6.1 (Eclipse Platform 3.6.1) To: org.eclipse.ui.ide [3.6.1.M20100825-0800] Cannot satisfy dependency: From: Eclipse Java Development Tools 3.6.2.r362_v20101117-0800-7z8XFW6FLFlmjJcvz03jyeFBLS_F (org.eclipse.jdt.feature.group 3.6.2.r362_v20101117-0800-7z8XFW6FLFlmjJcvz03jyeFBLS_F) To: org.eclipse.platform.feature.group 3.6.2 Cannot satisfy dependency: From: Eclipse Platform 3.6.2.r362_v20110210-9gF78Gs1FrIGnHDHWkEcopoN8AmxeZflGDGKQi (org.eclipse.platform.feature.group 3.6.2.r362_v20110210-9gF78Gs1FrIGnHDHWkEcopoN8AmxeZflGDGKQi) To: org.eclipse.ui.ide [3.6.2.M20101201-0800] 

Что мне делать?

2 Solutions collect form web for “Проблема установки JDT в Eclipse на Linux”

Мне кажется, что вы установили IDE с помощью yum, а затем зашли в среду IDE, чтобы установить новейшие средства разработки java. Если вы установите Eclipse из системы управления пакетами вашего дистрибутива Linux, вам также следует установить средства разработки из этой системы. Я уверен, что в yum есть пакет eclipse-jdt. Зависимость, вероятно, от eclipse-jdt до eclipse, что было убедительным решением, поскольку обратное является необязательным.

Есть два решения: либо придерживаться пакетов из вашей IDE, либо загружать архив с сайта eclipse. Первый вариант обеспечит стабильную среду, в которой все части будут работать вместе. Вторая даст вам последнюю (стабильную) версию всего, и у вас будет меньше проблем с такими конфликтами, когда вы добавляете / устанавливаете компоненты из среды IDE.

Я бы предложил просто загрузить Eclipse с веб-сайта и разархивировать его в вашей домашней папке. У меня были подобные конфликты в прошлом, и не использовать пакеты из ОС в этом случае просто помогли мне.

Я знаю, что это не тот ответ, который вы ищете, но я считаю приемлемой альтернативой, если вам нужно только установить IDE в вашу систему.

  • Проверьте версию пакета RPM, доступную в репозитории upstream, если у меня есть пользовательский, установленный
  • Поиск файлов, не установленных менеджером пакетов RPM
  • RHEL6 Установите MySql-Python без подключения к Интернету?
  • Невозможно установить видео плагины для Fedora 23
  • Ошибка обновления Yum: «невозможно запустить новый поток»
  • YUM не будет обновлять KERNEL
  • Кто-нибудь знает, почему два сервера показывают разные пакеты, доступные с yum
  • Эквивалент APTonCD для Fedora
  • Ошибка Yum в Centos: новичок
  • yum не выбирает переменную окружения YUM0
  • Обновлены ли yum?
  • Linux и Unix - лучшая ОС в мире.