Не удалось установить Internet Explorer!

Я выполнил эту ссылку для установки Internet Explorer.

Когда я запускаю следующую команду, открывается GUI:

ravbholua@ravbholua-Aspire-5315:~/ies4linux-2.99.0.1$ pwd /home/ravbholua/ies4linux-2.99.0.1 ravbholua@ravbholua-Aspire-5315:~/ies4linux-2.99.0.1$ ./ies4linux IEs4Linux 2 is developed to be used with recent Wine versions (0.9.x). It seems that you are using an old version. It's recommended that you update your wine to the latest version (Go to: winehq.com). 

Обратите внимание на сообщение после выполнения указанной выше команды. Но я не думаю, что моя старая версия, как упоминалось выше. См. Ниже, чтобы узнать мою версию:

 ravbholua@ravbholua-Aspire-5315:~/ies4linux-2.99.0.1$ wine --version wine-1.7.4 

Моя последняя версия. Теперь в графическом интерфейсе я выбираю IE6 для установки. Но он не может установить, и я получаю следующую ошибку:

 An error ocurred when downloading. Please run IEs4Linux again. Corrupted file: ie6/EN-US/VGX.CAB 

Скажите, как установить IE?

    3 Solutions collect form web for “Не удалось установить Internet Explorer!”

    В некоторых случаях вы можете использовать плагин для своего браузера, который изменит пользовательский аккаунт вашего браузера, чтобы он «обманывал» веб-сайт, думая о том, что вы используете browserX при использовании браузера. В прошлом это работало на некоторых сайтах. Вот один из таких плагинов для Firefox, например, user-agent-switcher .

    Задний план

    Когда браузер подключается к веб-сайту, он отправляет строки, такие как идентификация, используя эту строку, «пользовательский агент».

    Mozilla / 5.0 (X11, Linux x86_64) AppleWebKit / 537.36 (KHTML, например, Gecko) Chrome / 27.0.1453.110 Safari / 537.36

    Подробности выше приведены ниже:

    ss информации о пользователе

    Вышеупомянутая строка Chrome – из системы Linux. Вы можете видеть, что вы делаете, перейдя на этот сайт, User Agent String.Com .

    Используя плагин, такой как упомянутый выше, вы можете манипулировать «пользовательским агентом» вашего браузера, чтобы быть чем угодно. В этом случае вы меняете его в соответствии со строкой «пользовательский агент» для другого браузера, в данном случае – Internet Explorer (IE).

    Что-то вроде этого:

    Mozilla / 5.0 (совместимый MSIE 10.0, Windows NT 6.1, Trident / 6.0)

    Обратите внимание на сообщение после выполнения указанной выше команды. Но я не думаю, что моя старая версия, как упоминалось выше.

    Интересно, имеет ли это какое-то отношение к этому .

    Версия 2.99.0.1 не работает из-за коробки в новых версиях Wine и KDE. Решение состоит в создании символической ссылки с

     sudo ln -sv /usr/bin/winecfg /usr/bin/wineprefixcreate 

    а затем запустите ./ies4linux с опцией командной строки –no-gui.

    И, пожалуйста, скажите, что вы делаете это только для проверки веб-разработчиков на IE6. Этот браузер – кошмар . http://www.ie6countdown.com/

    ies4linux является древним. Хотя вы можете заставить его работать с текущими версиями Wine, вам будет лучше, не беспокоясь об установке IE в Wine: Microsoft предоставляет виртуальные машины с предустановленной Windows + IE.

    Вот новость о выпуске modern.ie от 01/31/2013

    Microsoft в четверг запустила Modern.ie, набор бесплатных инструментов и сервисов, предназначенных для облегчения написания лучшего кода в различных операционных системах, браузерах и устройствах. Но это также попытка сохранить код разработчиков для ПК и Windows с акцентом на Internet Explorer.

    Linux и Unix - лучшая ОС в мире.