Intereting Posts
Как напечатать строку в конце строки с помощью awk? Grep и подсчет совпадающих строк Получение черных элементов управления при запуске linux на vmware на окнах Установка каталога mergerfs с привязкой mount под lxc не показывает ничего, кроме прав root или 555 iptables маршрутизирует маркированные пакеты с маршрутизатора на ПК и маршрутизирует их обратно на маршрутизатор Как отформатировать 16-гигабайтный pendrive для хранения всего 2 ГБ Добавление префиксов / суффиксов в имена файлов без их повторного ввода? Почему `cp -a. / dir` копировать содержимое вместо каталога? Запуск gnome-keyring-daemon в CentOS? Конфигурация FTP-сервера (VSFTP) «write_enable = YES» для каждого пользователя команда оболочки, чтобы знать дату изготовления компьютера Невозможно увидеть Fedora 20, когда он загружает три раза с Debian 7 и openSuSe 13.1 iPod Nano 6G на Linux Выберите код в vim Многопользовательская мышь для мыши и мыши с поддержкой Linux

Как безопасно обновить версию GTK +?

Я устанавливаю попытку установить расширение, которое требует gtk + 3.16, но моя текущая версия – 3.14 на Debian Jessie 8. Сообщение об ошибке, которое дает мне расширение

gtkbuilder: required gtk+ version 3.16, current version is 3.14

Я просматриваю диспетчер синаптических пакетов, чтобы узнать, могу ли я найти пакет, но мне не повезло. Я сделал несколько поисков, и я нашел этот gnome ftp https://ftp.gnome.org/pub/gnome/sources/gtk+/3.16/

Я загрузил пакет, распаковал его с помощью sudo tar xf gtk+-3.16.4.tar.xz затем я побежал ./configure он работал некоторое время, пока он не ударил

 Requested 'glib-2.0 >= 2.43.4' but version of GLib is 2.42.1 Requested 'atk >= 2.15.1' but version of Atk is 2.14.0 Consider adjusting the PKG_CONFIG_PATH environment variable if you installed software in a non-standard prefix. Alternatively, you may set the environment variables BASE_DEPENDENCIES_CFLAGS and BASE_DEPENDENCIES_LIBS to avoid the need to call pkg-config. 

Должен ли я продолжать устанавливать каждую зависимость один за другим, пока это не будет порождать ошибки у меня или есть способ, которым он может быть легко установлен без необходимости установки каждой ошибки зависимостей. Обычно одна зависимость зависит от множества других зависимостей, и это может занять много времени. Любые советы или предложения будут высоко оценены.

UPDATE: в настоящее время я выполняю установку каждого маршрута зависимости, который я установил atk 2.15.1 и glib 2.43.4 и он скомпилирован без ошибок. Но когда я пытаюсь ./configure на gtk + -3.16-4, я получаю следующую ошибку.

 *** 'pkg-config --modversion glib-2.0' returned 2.43.4, but GLIB (2.42.1) *** was found! If pkg-config was correct, then it is best *** to remove the old version of GLib. You may also be able to fix the error *** by modifying your LD_LIBRARY_PATH enviroment variable, or by editing *** /etc/ld.so.conf. Make sure you have run ldconfig if that is *** required on your system. *** If pkg-config was wrong, set the environment variable PKG_CONFIG_PATH *** to point to the correct configuration files no configure: error: *** GLIB 2.43.4 or better is required. The latest version of *** GLIB is always available from ftp://ftp.gtk.org/pub/gtk/. 

Я запускал pkg-config --modversion glib-2.0 а выход был 2.43.4 что означает, что у меня есть правильная версия glib, 2.43.4 в сообщении об ошибке, если это произойдет, чтобы установить переменную окружения «PKG_CONFIG_PATH, чтобы указать на правильные файлы конфигурации», но я не знаю, к какому файлу он должен указывать или каков путь к этому файлу.