Intereting Posts
ждать сигнала убийства Как обновить Puppy Linux? Сохранять вход bash в верхней строке экрана Как создать стандартную настройку dconf по умолчанию, начиная с только что созданной пользовательской конфигурации ad-hoc? Установка драйвера WiFi на машине без Интернета используя stat, чтобы обеспечить метку времени для касания скрипт ffmpeg – разрезание видео на несколько фрагментов Как отправить весь вывод в `logger` в оболочке POSIX? В HP-UX, как я могу записывать сообщения системных событий Information Only Only в syslog.log? AWK с одним десятичным знаком Использование переменной внутри последовательности команд в bash для дополнения существующей строки – синтаксическая ошибка или ошибочный дизайн? не могу найти какой процесс использует память Как установить oracle11gr2 на ubuntu 15.04? Мониторинг питания системы Lenovo x3650 m5 (8871) на RHEL7 Почему я не могу передать две пустые строки в одну пустую строку?

Как получить GNU параллельно на Amazon Linux?

Предпочтительно без необходимости скомпилировать его из источника. Я попытался добавить репозитории, найденные в Google: CentOS 6 и CentOS 5 , но оба дают мне:

[ec2-user@ip-10-0-1-202 yum.repos.d]$ sudo yum install parallel -y Loaded plugins: priorities, update-motd, upgrade-helper amzn-main/2016.03 | 2.1 kB 00:00 amzn-updates/2016.03 | 2.3 kB 00:00 952 packages excluded due to repository priority protections Resolving Dependencies --> Running transaction check ---> Package parallel.noarch 0:20160522-1.1 will be installed --> Processing Dependency: /usr/bin/fish for package: parallel-20160522-1.1.noarch --> Processing Dependency: /usr/bin/ksh for package: parallel-20160522-1.1.noarch --> Processing Dependency: /usr/bin/zsh for package: parallel-20160522-1.1.noarch --> Processing Dependency: /bin/pdksh for package: parallel-20160522-1.1.noarch --> Processing Dependency: /usr/bin/ksh for package: parallel-20160522-1.1.noarch --> Processing Dependency: /usr/bin/zsh for package: parallel-20160522-1.1.noarch --> Processing Dependency: /usr/bin/fish for package: parallel-20160522-1.1.noarch --> Processing Dependency: /bin/pdksh for package: parallel-20160522-1.1.noarch --> Finished Dependency Resolution Error: Package: parallel-20160522-1.1.noarch (home_tange) Requires: /bin/pdksh Error: Package: parallel-20160522-1.1.noarch (home_tange) Requires: /usr/bin/fish Error: Package: parallel-20160522-1.1.noarch (home_tange) Requires: /usr/bin/zsh Error: Package: parallel-20160522-1.1.noarch (home_tange) Requires: /usr/bin/ksh You could try using --skip-broken to work around the problem You could try running: rpm -Va --nofiles --nodigest 

Установка может быть выполнена менее чем за 10 секунд, если вы выполните официальные инструкции по установке:

http://git.savannah.gnu.org/cgit/parallel.git/tree/README

У меня была такая же проблема с pdksh, но я смог обойти ее. Я смог установить GNU параллельно без pdksh и, следовательно, не имел никаких ошибок, путем:

  1. Загрузка rpmforge
  2. rpm установка rpmforge
  3. yum установка параллель.