Обновление glibc до 2.21 на CentOS

Я не очень разбираюсь в Linux, поэтому, пожалуйста, несите меня. Мне нужно установить MySQL 5.6 в поле CentOS. Я нашел то, что казалось простым учебником , но первая команда ( sudo yum install my-sql-community-server ) привела к этой группе ошибок:

введите описание изображения здесь

Я запустил yum list glibc чтобы узнать, какая версия имеет мой бокс, и он придумал glibc.x86_64 2.12-1.166.el6_7.7. Я попытался запустить yum -y update glibc , и он запускался без ошибок, но когда я снова проверяю версию, он все еще находится на одном и том же. Как обновить мою систему, чтобы библиотеки, которые требуется mysql?

  • Различные оболочки не будут запускать двоичный файл, который существует
  • Можно ли восстановить поврежденный libc на Redhat?
  • Кросс-компиляция GLIBC для моего ARM SoC
  • Какой был бы лучший способ обойти эту проблему glibc?
  • Как chroot предоставить новую версию glibc для приложения?
  • Задание локального libc вызывает глобальный libc?
  • Как создать исполняемые файлы, которые могут работать на старых системах на современных дистрибутивах?
  • CentOS 4.8 и glibc 2.5
  • One Solution collect form web for “Обновление glibc до 2.21 на CentOS”

    Этот учебник специфичен для RHEL 7 / CentOS 7. Он не будет работать для CentOS 6, именно потому, что пакеты ОС в CentOS 6 старше, чем то, что вам нужно для пакетов MySQL для CentOS 7. Вам нужно будет найти учебное пособие или инструкции по установке на CentOS 6; их много. Сначала вам нужно удалить пакет репозитория, который вы установили как часть этого руководства, затем вы можете начать работу на странице репозитория MySQL, http://dev.mysql.com/downloads/repo/yum/ .

    Linux и Unix - лучшая ОС в мире.