Файл конфигурации GIMP 2.9.4 не распознает установленные библиотеки

Недавно я загрузил последнюю версию GIMP (2.9.4) со своего веб-сайта и извлек ее. Я прочитал файл INSTALL и запустил скрипт configure. Однако, когда я это делаю, это терпит неудачу:

GIMP configuration failed. The following mandatory dependencies are missing: - babl >= 0.1.18 - gegl-0.3 >= 0.3.8 - atk >= 2.2.0 - gtk+-2.0 >= 2.24.10 *** Test for GTK+ failed. - gdk-pixbuf-2.0 >= 2.30.8 - gdk-pixbuf-csource *** Could not find gdk-pixbuf-csource in your PATH. - gexiv2 >= 0.6.1 - libtiff *** Checks for TIFF library failed - libjpeg *** JPEG library not found - libjpeg *** JPEG header file not found - libjpeg *** JPEG library is too old - liblzma >= 5.0.0 - libmypaint >= 1.3.0 - lcms2 >= 2.6 - Python 2 headers *** Please install them, or skip building the python scripting extension by *** passing --disable-python to configure (but then you will not be able *** to use scripts for GIMP that are written in Python). - PyGTK 2.10.4 or newer *** Please install it, or skip building the python scripting extension by *** passing --disable-python to configure (but then you will not be able *** to use scripts for GIMP that are written in Python). - pygtk-codegen-2.0 script *** Please install it, or skip building the python scripting extension by *** passing --disable-python to configure (but then you will not be able *** to use scripts for GIMP that are written in Python). - PyCairo 1.0.2 or newer *** Please install it, or skip building the python scripting extension by *** passing --disable-python to configure (but then you will not be able *** to use scripts for GIMP that are written in Python). 

Я установил все эти вручную через dnf, но почему-то все еще не распознает некоторые из простейших пакетов, таких как libjpeg . Кто-нибудь знает, почему он может не читать последние установленные пакеты? Я на Fedora 25.

  • Запретить GIMP повышать и активировать новые окна / вкладки
  • Сохранить изображение как 24 бит png
  • Как повернуть набор изображений из командной строки?
  • политика apt-cache gimp libgegl-0.2-0
  • Как установить gimp 2.8 на Debian Squeeze?
  • Тонкая настройка для производительности
  • Как конвертировать несколько файлов XCF в PNG?
  • Построить Gimp из библиотек пользовательского пути
  • One Solution collect form web for “Файл конфигурации GIMP 2.9.4 не распознает установленные библиотеки”

    Как упоминалось в комментарии от @ riccs_0x, вам не хватает нескольких пакетов разработки.

    Вместо того, чтобы находить и устанавливать их из управления пакетами один за другим, вы можете сообщить менеджерам пакетов об установке всех зависимостей GIMP-пакета вашего дистрибутива (в настоящее время это будет 2.8.22). За исключением всего, что не требовалось в 2.8.x вообще, и вы уже нашли libmypaint и достаточно недавний babl и gegl – это разрешит большинство, если не всех, проблем, с которыми вы столкнулись.

    Для версии GIMP 2.9.x может потребоваться более поздняя версия зависимостей, чем 2.8.x, но поскольку GIMP имеет тенденцию быть довольно консервативной с их повышением, у вас, скорее всего, будут такие.

    Для установки зависимостей исходных пакетов как yum, так и dnf предоставляют команду builddep. Я сам не использую Fedora и не могу попробовать, но моя первая попытка:

     dnf builddep gimp 
    Interesting Posts

    vim regex для поиска строк, содержащих string1 AND string2

    Информация о местонахождении Simfs hardlinks

    Список изменений файлов в определенной папке с огромным содержимым и несколькими уровнями подпапок (с достойной производительностью)

    Не удается подключить устройство USB к рабочей станции VMware 12.5

    Есть ли инструмент для чтения CD / DVD-дисков для Linux?

    Сценарий, который выводит среднюю строку из нескольких групп, из файла

    Как я могу загрузиться в chroot, не покидая текущей сессии ОС?

    В Centos, где хранятся файлы конфигурации по умолчанию или глобальные tmux-конфигурации?

    В чем разница между системой с consolekit и без нее?

    Как получить журнал загрузки ядра с помощью журналаctctl?

    Обновление kde до последней версии

    Клавиши для ноутбуков не работают

    Как я могу «сшить» псевдонимы оболочки?

    Настройка брандмауэра для амула на шлюзе OpenBSD 4.7

    Добавить приложения в программу запуска

    Linux и Unix - лучшая ОС в мире.