Как установить gimp 2.8 на Debian Squeeze?

Gimp 2.8 поставляется с множеством зависимостей. Как установить gimp 2.8 с зависимостями от Squeeze Debian?

3 Solutions collect form web for “Как установить gimp 2.8 на Debian Squeeze?”

В backports нет gimp2.8, поэтому самый простой способ – добавить тестовые репозитории на ваш компьютер:

echo "deb http://ftp.de.debian.org/debian/ testing main" | sudo tee -a /etc/apt/sources.list 

Затем вам нужно настроить приоритеты apt, чтобы сделать тестовую версию дополнительной для предотвращения обновления дистрибутива. Для этого

 echo "Package: * Pin: release a=stable Pin-Priority: 700 Package: * Pin: release a=testing Pin-Priority: 650" | sudo tee -a /etc/apt/preferences 

После этого вы можете обновить список пакетов:

 aptitude update 

И установите gimp2.8 из тестирования с помощью:

 aptitude -t testing install gimp 

Он будет разрешать зависимости и автоматически обновлять все необходимые пакеты.

Кроме того, вы можете заархивировать gimp самостоятельно, но это намного сложнее (:

Если вы не слишком жестко занимаете место на диске, самый простой способ объединить стабильную систему с последними версиями нескольких приложений – это запустить стабильную версию Debian и поддерживать установку Debian нестабильной или тестируемой в chroot .

Для руководства по настройке дистрибутива, подобного Debian, в chroot, см. Раздел « Как запустить 32-разрядные программы на 64-разрядном Debian / Ubuntu? (секция шрот). Руководство написано для 32-битного Ubuntu внутри 64-разрядного Ubuntu, но в равной степени относится к нестабильной внутри стабильной и Debian.

Настройте шрот и установите Gimp внутри него. Вы можете сделать обертку вне chroot, чтобы запустить chrooted Gimp. Поместите этот файл как /usr/local/bin/gimp (при условии, что вы установили хриплый chroot в /wheezy ):

 #!/bin/sh exec schroot -c /wheezy gimp 
 wget ftp://ftp.gimp.org/pub/gimp/v2.8/gimp-2.8.0.tar.bz2 mv gimp-2.8.0.tar.bz2 /tmp/ tar xf gimp-2.8.0.tar.bz2 cd gimp-2.8.0/ ./configure make all && make install 
  • apt-get ошибка установки программного обеспечения на Parrot OS
  • Установка пакета wordpress всегда требует apache?
  • Как установить cctrlapp на debian?
  • Установка пакета .deb в домашний каталог
  • Установка Java на OpenSuse
  • Как установить и использовать disp3d без паузы в R 3.3.2?
  • atom не может быть запущен, потому что libgtk-x11-2.0.so.0 не найден, но ldd может найти его
  • Как удалить java на Linux Mint 12
  • Является ли эта пропавшая ошибка зависимостей Python3 в Kazam Debian 8.5?
  • Как устранить эту проблему с дублирующимися источниками при установке новейшего Google Chrome Debian?
  • Как установить Skype на Debian 8?
  • Linux и Unix - лучшая ОС в мире.